summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/am-utils/am-utils-6.0.9-r1.ebuild')
-rw-r--r--net-fs/am-utils/am-utils-6.0.9-r1.ebuild55
1 files changed, 28 insertions, 27 deletions
diff --git a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
index 60cd688d6804..24110ea712d0 100644
--- a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
+++ b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
@@ -1,45 +1,46 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.12 2005/06/06 23:31:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.1 2003/10/16 15:54:15 drobbins Exp $
-inherit eutils
+IUSE="ldap"
+S=${WORKDIR}/${P}
DESCRIPTION="amd automounter and utilities"
-HOMEPAGE="http://www.am-utils.org/"
+HOMEPAGE="http://www.am-utils.org"
SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="ldap"
+DEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2 )"
-RDEPEND="ldap? ( >=net-nds/openldap-1.2 )"
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.51"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 amd64"
src_unpack() {
unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/am-utils-gdbm.patch
- libtoolize --copy --force && \
- aclocal && \
- autoconf && \
- automake || die "autotools failed"
+ cd ${S}
+ cat ${FILESDIR}/am-utils-gdbm.patch | patch -p1 || die
}
src_compile() {
- econf \
- $(use_with ldap) \
- --sysconfdir=/etc/amd \
- || die "configure failed"
- # does not build in parallel #67136
- emake -j1 || die "make failed"
+ local myconf
+
+ use ldap \
+ && myconf="${myconf} --without-ldap" \
+ || myconf="${myconf} --with-ldap"
+
+ myconf="${myconf} --sysconfdir=/etc/amd"
+
+ cd ${S}
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ make DESTDIR=${D} install || die
+
+ cp ${FILESDIR}/amd.conf ${D}/etc/amd
+ cp ${FILESDIR}/amd.net ${D}/etc/amd
- insinto /etc/amd
- doins "${FILESDIR}"/amd.{conf,net}
- newinitd "${FILESDIR}/amd.rc" amd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
}