summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/intersync/intersync-0.9.5.ebuild')
-rw-r--r--net-fs/intersync/intersync-0.9.5.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/net-fs/intersync/intersync-0.9.5.ebuild b/net-fs/intersync/intersync-0.9.5.ebuild
index 7ea0009f316b..698f201144ee 100644
--- a/net-fs/intersync/intersync-0.9.5.ebuild
+++ b/net-fs/intersync/intersync-0.9.5.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/intersync/intersync-0.9.5.ebuild,v 1.12 2005/05/06 00:03:06 swegener Exp $
-DESCRIPTION="advanced replicating networked filesystem"
-HOMEPAGE="http://www.inter-mezzo.org/"
-SRC_URI="ftp://ftp.inter-mezzo.org/pub/intermezzo/${P}.tar.gz"
+DESCRIPTION="Intermezzo is an advanced replicating networked filesystem."
+HOMEPAGE="http://www.inter-mezzo.org"
-LICENSE="GPL-2"
+LICENSE="GPL"
SLOT="0"
-KEYWORDS="x86"
-IUSE=""
+KEYWORDS="~x86"
-DEPEND="net-misc/curl
+DEPEND="net-ftp/curl
media-gfx/transfig
- >=dev-libs/glib-2
- >=gnome-base/libghttp-1.0.9-r3
+ >=dev-libs/glib-2*
+ >=gnome-base/libghttp-1.0.9
>=sys-kernel/linux-headers-2.4"
-src_compile() {
+SRC_URI="ftp://ftp.inter-mezzo.org/pub/intermezzo/${P}.tar.gz"
+
+src_compile () {
local myconf=""
has "net-www/apache" \
&& $myconf="${myconf} --with-apache-modules=/etc/apache/modules"
-
+
./configure \
--sysconfdir=/etc \
--localstatedir=/var \
--datadir=/usr/share \
--libdir=/lib \
${myconf}
+
emake || die "emake failed"
}
-src_install() {
+src_install () {
make DESTDIR=${D} install
- exeinto /etc/init.d ; newexe ${FILESDIR}/intersync.rc intersync
- insinto /etc/conf.d ; newins ${FILESDIR}/intersync.conf intersync
}