summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/samba/samba-3.0.9.ebuild')
-rw-r--r--net-fs/samba/samba-3.0.9.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-fs/samba/samba-3.0.9.ebuild b/net-fs/samba/samba-3.0.9.ebuild
index 6220d136fe6c..55be40eeebd3 100644
--- a/net-fs/samba/samba-3.0.9.ebuild
+++ b/net-fs/samba/samba-3.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.9.ebuild,v 1.2 2004/11/21 20:58:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.9.ebuild,v 1.3 2004/11/23 15:28:22 satya Exp $
inherit eutils flag-o-matic
#---------------------------------------------------------------------------
@@ -57,6 +57,12 @@ pkg_setup() {
ewarn "/etc/samba/private moved to /var/lib/samba/private"
ebeep
epause
+ local PRIVATEDIR=/var/lib/samba/private
+ local PRIVATE_SRC=/etc/samba/private
+ if [[ ! -r ${PRIVATEDIR}/secrets.tdb && -r ${PRIVATE_SRC}/secrets.tdb ]]; then
+ einfo "Copying ${PRIVATE_SRC}/* to ${PRIVATEDIR}/"
+ cp -af ${PRIVATE_SRC}/* ${D}${PRIVATEDIR}/
+ fi
}
#===========================================================================
src_unpack() {
@@ -362,13 +368,6 @@ pkg_postinst() {
# to mount smb shares don't get annoying warnings all the time..
#[ ! -e ${ROOT}/etc/samba/smb.conf ] && touch ${ROOT}/etc/samba/smb.conf
- local PRIVATE_DST=/var/lib/samba/private
- local PRIVATE_SRC=/etc/samba/private
- if [[ ! -r ${PRIVATE_DST}/secrets.tdb && -r ${PRIVATE_SRC}/secrets.tdb ]]; then
- einfo "Copying ${PRIVATE_SRC}/* to ${PRIVATE_DST}/"
- cp -af ${PRIVATE_SRC}/* ${D}${PRIVATE_DST}/
- fi
-
ewarn ""
ewarn "If you are upgrading from a Samba version prior to 3.0.2, and you"
ewarn "use Samba's password database, you must run the following command:"