summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/shfs/files/shfs-amd64-makefile.patch')
-rw-r--r--net-fs/shfs/files/shfs-amd64-makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-fs/shfs/files/shfs-amd64-makefile.patch b/net-fs/shfs/files/shfs-amd64-makefile.patch
new file mode 100644
index 000000000000..36797bcb09bc
--- /dev/null
+++ b/net-fs/shfs/files/shfs-amd64-makefile.patch
@@ -0,0 +1,14 @@
+--- shfs-0.31-1/shfs/Makefile.old 2003-10-14 23:54:50.000000000 -0400
++++ shfs-0.31-1/shfs/Makefile 2003-10-14 23:55:05.000000000 -0400
+@@ -15,9 +15,9 @@
+ SEARCHDIRS := -I- -I. -I${KERNEL_SOURCES}/include -I/usr/src/linux/include/
+
+ CC := gcc
+-CFLAGS = -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -Wall ${SEARCHDIRS} -DMODULE ${MVER} -D__KERNEL__ -DLINUX -DDEBUG_LEVEL=${DEBUG}
++CFLAGS = -O2 -mcmodel=kernel -fomit-frame-pointer -fno-strict-aliasing -pipe -Wall ${SEARCHDIRS} -DMODULE ${MVER} -D__KERNEL__ -DLINUX -DDEBUG_LEVEL=${DEBUG}
+ LINKER := ld
+-LDFLAGS = -m elf_i386 -r
++LDFLAGS = -r
+ LOADLIBES :=
+
+ all: ${ALL_TARGETS}