summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/gftp/gftp-2.0.14.ebuild')
-rw-r--r--net-ftp/gftp/gftp-2.0.14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-ftp/gftp/gftp-2.0.14.ebuild b/net-ftp/gftp/gftp-2.0.14.ebuild
new file mode 100644
index 000000000000..e031286986af
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-2.0.14.ebuild,v 1.1 2002/12/06 14:13:08 foser Exp $
+
+IUSE="nls gtk2"
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/x11
+ gtk2? ( >=x11-libs/gtk+-2.0.0 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ # do not use enable-{gtk20,gtkport} they are not recognized
+ # and will disable building the gtkport alltogether
+ use gtk2 \
+ && myconf="${myconf}" \
+ || myconf="${myconf} --disable-gtk20"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc COPYING ChangeLog AUTHORS README* THANKS \
+ TODO docs/USERS-GUIDE NEWS
+
+}