summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosip/ChangeLog13
-rw-r--r--net-libs/libosip/files/digest-libosip-0.8.81
-rw-r--r--net-libs/libosip/libosip-0.8.8.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/libosip/ChangeLog b/net-libs/libosip/ChangeLog
new file mode 100644
index 000000000000..b1065ca41282
--- /dev/null
+++ b/net-libs/libosip/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-libs/libosip
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header:
+
+*libosip-0.8.8 (27 aug 2002)
+
+ 27 Aug 2002; Paul Belt <gaarde@gentoo.org> :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-libs/libosip/files/digest-libosip-0.8.8 b/net-libs/libosip/files/digest-libosip-0.8.8
new file mode 100644
index 000000000000..a161939934f0
--- /dev/null
+++ b/net-libs/libosip/files/digest-libosip-0.8.8
@@ -0,0 +1 @@
+MD5 840b5508eec9ae7fae998059b7bf63eb libosip-0.8.8.tar.gz 382002
diff --git a/net-libs/libosip/libosip-0.8.8.ebuild b/net-libs/libosip/libosip-0.8.8.ebuild
new file mode 100644
index 000000000000..89eac16c1e34
--- /dev/null
+++ b/net-libs/libosip/libosip-0.8.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/libosip-0.8.8.ebuild,v 1.1 2002/08/28 00:44:39 gaarde Exp $
+
+# AUTHOR: Paul Belt <gaarde@gentoo.org>
+
+DESCRIPTION="This is the oSIP library (for Open SIP). It has been designed to provide the Internet Community a simple way to support the Session Initiation Protocol. SIP is described in the RFC2543 which is available at http://www.ietf.org/rfc/rfc2543.txt."
+
+# In french
+# if use french; then \
+# HOMEPAGE="http://www.linphone.org/"
+# elsif use english; then \
+# HOMEPAGE="http://www.linphone.org/?lang=us"
+# fi
+
+# In english
+HOMEPAGE="http://www.linphone.org/?lang=us"
+
+SRC_URI="http://www.linphone.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+
+SLOT="1"
+
+KEYWORDS="x86"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ EXTRA_FLAGS=''
+
+ if use pic; then
+ flags="${flags} --with-pic";
+ else
+ flags="${flags} --without-pic"
+ fi
+
+ econf ${EXTRA_FLAGS} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO
+}