summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/arpd/arpd-0.2-r1.ebuild')
-rw-r--r--net-misc/arpd/arpd-0.2-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-misc/arpd/arpd-0.2-r1.ebuild b/net-misc/arpd/arpd-0.2-r1.ebuild
index 9f308f3b02ee..a5d076dde55f 100644
--- a/net-misc/arpd/arpd-0.2-r1.ebuild
+++ b/net-misc/arpd/arpd-0.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arpd/arpd-0.2-r1.ebuild,v 1.1 2010/02/16 21:08:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arpd/arpd-0.2-r1.ebuild,v 1.2 2010/09/16 22:47:14 xmw Exp $
EAPI="3"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="ARP server which claims all unassigned addresses (for network monitoring or simulation)"
HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
@@ -25,11 +25,11 @@ S=${WORKDIR}/${PN}
src_prepare() {
epatch "${FILESDIR}"/arpd.c.patch
epatch "${FILESDIR}"/${P}-libevent.patch
+
+ #fix bug 337481, replace test on libevent.a with libevent.so
+ epatch "${FILESDIR}"/${P}-buildsystem-libevent-test.patch
- sed -i \
- -e 's|$withval/lib/libevent.a; then||' \
- -e 's|if test -f $withval/include/event.h -a -f|if test -f $withval/include/event.h -a -f $withval/lib/libevent.a; then|' \
- configure || die "sed failed"
+ eautoreconf
}
src_configure() {