summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/bk2site/bk2site-1.1.8-r1.ebuild')
-rw-r--r--net-misc/bk2site/bk2site-1.1.8-r1.ebuild43
1 files changed, 21 insertions, 22 deletions
diff --git a/net-misc/bk2site/bk2site-1.1.8-r1.ebuild b/net-misc/bk2site/bk2site-1.1.8-r1.ebuild
index 0099c1e3fa7e..a757c09fa968 100644
--- a/net-misc/bk2site/bk2site-1.1.8-r1.ebuild
+++ b/net-misc/bk2site/bk2site-1.1.8-r1.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bk2site/bk2site-1.1.8-r1.ebuild,v 1.13 2004/07/15 02:40:20 agriffis Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Jon Nelson <jnelson@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bk2site/bk2site-1.1.8-r1.ebuild,v 1.1 2002/04/06 07:28:16 jnelson Exp $
+
+S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="bk2site will transform your Netscape bookmarks file into a yahoo-like website with slashdot-like news."
-SRC_URI="mirror://sourceforge/bk2site/${P}.tar.gz"
+SRC_URI="http://prdownloads.sourceforge.net/bk2site/${P}.tar.gz"
HOMEPAGE="http://bk2site.sourceforge.net/"
-KEYWORDS="x86 sparc "
-SLOT="0"
-LICENSE="GPL-2"
DEPEND=""
#RDEPEND=""
@@ -16,19 +15,19 @@ DEPEND=""
src_unpack() {
unpack $A
- # Apply any patches available for this version
- local patches=`echo ${FILESDIR}/${PV}.[0-9][0-9][0-9]`
- case "$patches" in
- *\])
- ;; # globbing didn't work; no patches available
- *)
- cd $S
- for a in $patches; do
- patch -p0 < $a
- done
- ;;
- esac
- patch -f -p0 < ${FILESDIR}/ebuild.patch
+ # Apply any patches available for this version
+ local patches=`echo ${FILESDIR}/${PV}.[0-9][0-9][0-9]`
+ case "$patches" in
+ *\])
+ ;; # globbing didn't work; no patches available
+ *)
+ cd $S
+ for a in $patches; do
+ patch -p0 < $a
+ done
+ ;;
+ esac
+ patch -f -p0 < ${FILESDIR}/ebuild.patch
}
src_compile() {
@@ -45,7 +44,7 @@ src_install () {
make DESTDIR=${D} install || die
insinto /etc/bk2site
doins indexbase.html newbase.html otherbase.html searchbase.html
- dodoc bk2site.html *.gif
+ dodoc bk2site.html *.gif
dodoc README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
exeinto /home/httpd/cgi-bin/bk2site
doexe *.pl