summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/urlview/urlview-0.9.ebuild')
-rw-r--r--net-misc/urlview/urlview-0.9.ebuild55
1 files changed, 18 insertions, 37 deletions
diff --git a/net-misc/urlview/urlview-0.9.ebuild b/net-misc/urlview/urlview-0.9.ebuild
index b3cbaa1b5a36..09951c37b0fa 100644
--- a/net-misc/urlview/urlview-0.9.ebuild
+++ b/net-misc/urlview/urlview-0.9.ebuild
@@ -1,54 +1,35 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.23 2005/10/18 21:35:15 agriffis Exp $
-
-inherit eutils
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.1 2001/07/18 00:46:22 lamer Exp $
+S=${WORKDIR}/${P}
DESCRIPTION="extracts urls from text and will send them to another app"
-HOMEPAGE="http://www.mutt.org"
SRC_URI="ftp://gd.tuwien.ac.at/infosys/mail/mutt/contrib/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 s390 sparc x86"
-IUSE=""
-
+HOMEPAGE="http://www.mutt.org"
DEPEND=">=sys-libs/ncurses-5.2"
-src_compile() {
- epatch ${FILESDIR}/no-trailing-newline.patch
- epatch ${FILESDIR}/include-fix.patch
-
- ./configure \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc \
- --host=${CHOST} || die "Configure Failed"
+#RDEPEND=""
- emake || die "Parallel Make Failed"
+src_compile() {
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man \
+ --prefix=/usr --sysconfdir=/etc --host=${CHOST}
+
+ try emake
+ #try make
}
src_install () {
- dodir /usr/share/man/man1
-
- make infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- prefix=${D}/usr \
- sysconfdir=${D}/etc \
- install || die "Installation Failed"
+
+ # try make prefix=${D}/usr install
- dodoc README INSTALL ChangeLog AUTHORS COPYING sample.urlview
- dobin url_handler.sh
+ try make DESTDIR=${D} install
+ dodoc README INSTALL ChangeLog AUTHORS COPYING sample.urlview
+ dobin url_handler.sh
}
pkg_postinst() {
- echo
einfo "There is a sample.urlview in /usr/share/doc/${P}"
einfo "You can also customize /usr/bin/url_handler.sh"
- echo
- einfo "If using urlview from mutt, you may need to "set pipe_decode" in"
- einfo "your ~/.muttrc to prevent garbled URLs."
- echo
}