summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/vtun/vtun-2.6.ebuild')
-rw-r--r--net-misc/vtun/vtun-2.6.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/net-misc/vtun/vtun-2.6.ebuild b/net-misc/vtun/vtun-2.6.ebuild
index 2f99354a2858..fe38f12016da 100644
--- a/net-misc/vtun/vtun-2.6.ebuild
+++ b/net-misc/vtun/vtun-2.6.ebuild
@@ -1,8 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-2.6.ebuild,v 1.12 2005/11/13 06:21:54 dragonheart Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-2.6.ebuild,v 1.1 2003/10/18 02:04:50 zul Exp $
IUSE="ssl"
@@ -10,22 +8,18 @@ S=${WORKDIR}/vtun
DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression"
SRC_URI="mirror://sourceforge/vtun/${P}.tar.gz"
HOMEPAGE="http://vtun.sourceforge.net/"
-KEYWORDS="x86 sparc ~amd64 alpha ~ppc"
+KEYWORDS="x86 sparc "
LICENSE="GPL-2"
SLOT="0"
# NOTE: you also need the tun/tap driver compiled into your kernel
# to do tun/tap tunneling
-DEPEND="virtual/libc
+DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- =dev-libs/lzo-1*
+ >=dev-libs/lzo-1.07
sys-devel/bison
ssl? ( >=dev-libs/openssl-0.9.6c )"
-RDEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
- ssl? ( >=dev-libs/openssl-0.9.6c )"
-
src_unpack() {
unpack ${A} && cd ${S} || die
epatch ${FILESDIR}/${PN}-${PV}-makefile.patch
@@ -34,7 +28,7 @@ src_unpack() {
src_compile() {
local use_opts
use_opts=""
- if ! use ssl
+ if [ -z "`use ssl`" ]
then
use_opts="--disable-ssl"
fi