summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wol/wol-0.7.1.ebuild')
-rw-r--r--net-misc/wol/wol-0.7.1.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/net-misc/wol/wol-0.7.1.ebuild b/net-misc/wol/wol-0.7.1.ebuild
index f97eef07f4a6..ff533fe00a76 100644
--- a/net-misc/wol/wol-0.7.1.ebuild
+++ b/net-misc/wol/wol-0.7.1.ebuild
@@ -1,23 +1,32 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wol/wol-0.7.1.ebuild,v 1.4 2005/09/22 21:00:11 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wol/wol-0.7.1.ebuild,v 1.1 2005/01/04 01:21:12 wschlich Exp $
-DESCRIPTION="Wake On LAN client, wakes up hardware that is Magic Packet compliant."
+inherit eutils flag-o-matic
+
+DESCRIPTION="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
HOMEPAGE="http://ahh.sourceforge.net/wol/"
SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc -ppc-macos"
-IUSE="nls"
+KEYWORDS="~x86"
+IUSE="debug"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
src_compile() {
- econf \
- $(use_enable nls) \
- || die "configure failed"
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
emake || die "make failed"
}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc README ChangeLog TODO AUTHORS
+ dodoc README ChangeLog TODO
}