summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nxclient/ChangeLog9
-rw-r--r--net-misc/nxclient/Manifest4
-rw-r--r--net-misc/nxclient/files/1.2.2/50nxclient3
-rw-r--r--net-misc/nxclient/files/digest-nxclient-1.2.21
-rw-r--r--net-misc/nxclient/nxclient-1.2.2.ebuild62
5 files changed, 77 insertions, 2 deletions
diff --git a/net-misc/nxclient/ChangeLog b/net-misc/nxclient/ChangeLog
new file mode 100644
index 000000000000..aa3b7b573c7f
--- /dev/null
+++ b/net-misc/nxclient/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/nxclient
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.1 2003/08/27 03:12:19 stuart Exp $
+
+*nxclient-1.2.2 (27 Aug 2003)
+
+ 27 Aug 2003; stuart nxclient-1.2.2.ebuild, files/1.2.2/50nxclient:
+ Initial import
+
diff --git a/net-misc/nxclient/Manifest b/net-misc/nxclient/Manifest
index 9194b5df3ba9..dffbf8cec5e9 100644
--- a/net-misc/nxclient/Manifest
+++ b/net-misc/nxclient/Manifest
@@ -1,4 +1,4 @@
-MD5 02c8d16464bcf3ee5683f7fd5abb40df nxclient-1.2.2.ebuild 1687
-MD5 50bda00a6885d3024a3f041d3f0c4939 ChangeLog 244
+MD5 5fb57f2268d0ff6a86101bd208256d25 nxclient-1.2.2.ebuild 1688
+MD5 612ef21b3a030ee3333170662ae201cb ChangeLog 334
MD5 2d2350797ee95d01a2c1fa5e2d0c2207 files/digest-nxclient-1.2.2 72
MD5 a2e15c37686ddad8dd3854b2b9b70700 files/1.2.2/50nxclient 57
diff --git a/net-misc/nxclient/files/1.2.2/50nxclient b/net-misc/nxclient/files/1.2.2/50nxclient
new file mode 100644
index 000000000000..3549ed81565b
--- /dev/null
+++ b/net-misc/nxclient/files/1.2.2/50nxclient
@@ -0,0 +1,3 @@
+PATH=/usr/NX/bin
+ROOTPATH=/usr/NX/bin
+LDPATH=/usr/NX/lib
diff --git a/net-misc/nxclient/files/digest-nxclient-1.2.2 b/net-misc/nxclient/files/digest-nxclient-1.2.2
new file mode 100644
index 000000000000..7ee7d20ae6c5
--- /dev/null
+++ b/net-misc/nxclient/files/digest-nxclient-1.2.2
@@ -0,0 +1 @@
+MD5 a23f4d2610b9ff48ea4eee7a044652b1 nxclient-1.2.2-31.i386.rpm 2668654
diff --git a/net-misc/nxclient/nxclient-1.2.2.ebuild b/net-misc/nxclient/nxclient-1.2.2.ebuild
new file mode 100644
index 000000000000..2577946c674e
--- /dev/null
+++ b/net-misc/nxclient/nxclient-1.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit rpm
+
+DESCRIPTION="NXClient is a X11/VNC/NXServer client especially tuned for using remote desktops over low-bandwidth links such as the Internet"
+HOMEPAGE="www.nomachine.com"
+
+IUSE=""
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -alpha -mips"
+RESTRICT="nostrip"
+
+# this ebuild deals with release 31 of NXClient 1.2.2
+MY_PV="${PV}-31"
+SRC_URI="http://www.nomachine.com/download/nxclient/RedHat-9.0/nxclient-${MY_PV}.i386.rpm"
+
+DEPEND=">=media-libs/jpeg-6b-r3
+ >=sys-libs/glibc-2.3.2-r1
+ >=sys-libs/zlib-1.1.4-r1
+ >=x11-base/xfree-4.3.0-r2
+ >=net-misc/nxssh-1.2.2
+ >=net-misc/nxproxy-1.2.2
+ >=dev-libs/expat-1.95.6-r1
+ >=media-libs/fontconfig-2.2.0-r2
+ >=media-libs/freetype-2.1.4
+ >=media-libs/jpeg-6b-r3"
+
+S="${WORKDIR}"
+
+src_compile() {
+ return;
+}
+
+src_install() {
+ exeinto /usr/NX/bin
+ doexe usr/NX/bin/nxartsdstatus
+ doexe usr/NX/bin/nxclient
+# doexe usr/NX/bin/nxproxy
+# doexe usr/NX/bin/nxssh
+
+# insinto /usr/NX/lib
+# dolib usr/NX/lib/libXcomp.so.1.2.2
+
+ insinto /usr/NX/share
+ doins usr/NX/share/client.id_dsa.key
+ insinto /usr/NX/share/icons
+ doins usr/NX/share/icons/*
+ insinto /usr/NX/share/images
+ doins usr/NX/share/images/*.png
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/50nxclient
+
+ insinto /usr/kde/3.1/share/applnk/Internet
+ doins "usr/NX/share/applnk/NX Client for Linux/nxclient-admin.desktop"
+ doins "usr/NX/share/applnk/NX Client for Linux/nxclient-help.desktop"
+ doins "usr/NX/share/applnk/NX Client for Linux/nxclient-wizard.desktop"
+ doins "usr/NX/share/applnk/NX Client for Linux/nxclient.desktop"
+}