summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog5
-rw-r--r--net-p2p/ktorrent/ktorrent-4.1.1.ebuild102
2 files changed, 4 insertions, 103 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index b715f0e017ed..6d3ba38dc5cd 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.175 2012/03/10 16:24:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.176 2012/03/12 09:30:36 johu Exp $
+
+ 12 Mar 2012; Johannes Huber <johu@gentoo.org> -ktorrent-4.1.1.ebuild:
+ Remove old.
10 Mar 2012; Brent Baude <ranger@gentoo.org> ktorrent-4.1.2.ebuild:
Marking ktorrent-4.1.2 ppc for bug 394867
diff --git a/net-p2p/ktorrent/ktorrent-4.1.1.ebuild b/net-p2p/ktorrent/ktorrent-4.1.1.ebuild
deleted file mode 100644
index afaa8e026745..000000000000
--- a/net-p2p/ktorrent/ktorrent-4.1.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.1.1.ebuild,v 1.6 2011/09/06 20:38:24 dilfridge Exp $
-
-EAPI=4
-
-KDE_SCM="git"
-KDE_MINIMAL="4.5"
-LIBKT_VERSION_MIN="${PV}"
-LIBKT_VERSION_MAX="99999999"
-if [[ ${PV} != 9999* ]]; then
- inherit versionator
- # upstream likes to skip that _ in beta releases
- MY_PV="${PV/_/}"
- LIBKT_VERSION_MIN=$(($(get_major_version)-3)).$(get_version_component_range 2-3 ${PV})
- LIBKT_VERSION_MAX=$(($(get_major_version)-3)).$(($(get_version_component_range 2)+1))
- MY_P="${PN}-${MY_PV}"
- KDE_HANDBOOK="optional"
- KDE_DOC_DIRS="doc"
-
- KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
- fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
- pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
- sr@latin sv tr uk zh_CN zh_TW"
- SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}"/"${MY_P}"
-
- KEYWORDS="amd64 ppc ~ppc64 x86"
-else
- LIBKT_VERSION_MIN="${PV}"
- LIBKT_VERSION_MAX="99999999"
- KEYWORDS=""
-fi
-
-inherit kde4-base
-
-DESCRIPTION="A BitTorrent program for KDE."
-HOMEPAGE="http://ktorrent.org/"
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
-+magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
-+upnp webinterface +zeroconf"
-
-COMMONDEPEND="
- <net-libs/libktorrent-${LIBKT_VERSION_MAX}
- >=net-libs/libktorrent-${LIBKT_VERSION_MIN}
- infowidget? ( dev-libs/geoip )
- mediaplayer? ( >=media-libs/taglib-1.5 )
- plasma? ( $(add_kdebase_dep libtaskmanager) )
- rss? ( $(add_kdebase_dep kdepimlibs) )
- shutdown? (
- $(add_kdebase_dep libkworkspace)
- $(add_kdebase_dep solid)
- )
-"
-DEPEND="${COMMONDEPEND}
- dev-libs/boost
- sys-devel/gettext
-"
-RDEPEND="${COMMONDEPEND}
- ipfilter? (
- app-arch/bzip2
- app-arch/unzip
- $(add_kdebase_dep kdebase-kioslaves)
- )
- kross? ( $(add_kdebase_dep krosspython) )
-"
-
-src_prepare() {
- if ! use plasma; then
- sed -i \
- -e "s:add_subdirectory(plasma):#nada:g" \
- CMakeLists.txt || die "Failed to make plasmoid optional"
- fi
-
- kde4-base_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
- $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
- $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
- $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
- $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
- $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
- $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
- $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
- $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
- $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
- $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
- $(cmake-utils_use_enable search SEARCH_PLUGIN)
- $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
- $(cmake-utils_use_enable stats STATS_PLUGIN)
- $(cmake-utils_use_enable upnp UPNP_PLUGIN)
- $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
- $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
- )
- kde4-base_src_configure
-}