summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/massxpert/ChangeLog8
-rw-r--r--sci-chemistry/massxpert/files/massxpert-2.0.4-gentoo.patch84
-rw-r--r--sci-chemistry/massxpert/massxpert-2.0.4.ebuild57
3 files changed, 148 insertions, 1 deletions
diff --git a/sci-chemistry/massxpert/ChangeLog b/sci-chemistry/massxpert/ChangeLog
index 0ba2479d8488..9c116623609f 100644
--- a/sci-chemistry/massxpert/ChangeLog
+++ b/sci-chemistry/massxpert/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/massxpert
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.6 2009/09/18 20:59:44 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.7 2009/09/19 18:09:41 wired Exp $
+
+*massxpert-2.0.4 (19 Sep 2009)
+
+ 19 Sep 2009; Alex Alexander <wired@gentoo.org> +massxpert-2.0.4.ebuild,
+ +files/massxpert-2.0.4-gentoo.patch:
+ version bump, bug 284344
18 Sep 2009; Alex Alexander <wired@gentoo.org> massxpert-1.7.6.ebuild:
updated Qt deps, switched to EAPI 2
diff --git a/sci-chemistry/massxpert/files/massxpert-2.0.4-gentoo.patch b/sci-chemistry/massxpert/files/massxpert-2.0.4-gentoo.patch
new file mode 100644
index 000000000000..63cbe2340008
--- /dev/null
+++ b/sci-chemistry/massxpert/files/massxpert-2.0.4-gentoo.patch
@@ -0,0 +1,84 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8085e0a..eaae8ce 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,10 +23,10 @@ SET (CMAKE_VERBOSE_MAKEFILE ON)
+
+ #############################################################
+ # Enable warnings and treat them as errors
+-SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall -Werror.")
++SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall.")
+
+ IF (PEDANTIC)
+- ADD_DEFINITIONS (-Wall -Werror)
++ ADD_DEFINITIONS (-Wall)
+ ENDIF (PEDANTIC)
+
+ #############################################################
+@@ -51,9 +51,9 @@ ENDIF (WIN32)
+ IF (UNIX AND NOT APPLE)
+ SET (MASSXPERT_BIN_DIR ${CMAKE_INSTALL_PREFIX}/bin)
+ SET (MASSXPERT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert)
+- SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib/massxpert/plugins)
++ SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/massxpert/plugins)
+ SET (MASSXPERT_LOCALE_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert/locales)
+- SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert)
++ SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert-${VERSION})
+ SET (MASSXPERT_USERMAN_DIR ${MASSXPERT_DOC_DIR}/usermanual)
+ ENDIF (UNIX AND NOT APPLE)
+
+@@ -122,10 +122,6 @@ IF (${BUILD_PROGRAM})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The desktop file
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert.desktop
+@@ -165,10 +161,6 @@ IF (${BUILD_DATA})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (data)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-data.7
+@@ -201,10 +193,6 @@ IF (${BUILD_USERMANUAL})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (user manual)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-doc.7
+diff --git a/gui/configurationSettingsDlg.cpp b/gui/configurationSettingsDlg.cpp
+index bf595d5..82cad21 100644
+--- a/gui/configurationSettingsDlg.cpp
++++ b/gui/configurationSettingsDlg.cpp
+@@ -309,13 +309,11 @@ namespace massXpert
+ bool
+ ConfigurationSettingsDlg::checkLocalizationDir(const QDir &dir)
+ {
+- // At the moment there is the french translation: massxpert_fr.qm
++ // Gentoo provides optional installing of translations.
++ // If you decide not to have translations, then this check
++ // would fail.
+
+- QString filePath(dir.absolutePath() +
+- QDir::separator() +
+- "massxpert_fr.qm");
+-
+- return QFile::exists(filePath);
++ return true;
+ }
+
+
diff --git a/sci-chemistry/massxpert/massxpert-2.0.4.ebuild b/sci-chemistry/massxpert/massxpert-2.0.4.ebuild
new file mode 100644
index 000000000000..4b3e35685c38
--- /dev/null
+++ b/sci-chemistry/massxpert/massxpert-2.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-2.0.4.ebuild,v 1.1 2009/09/19 18:09:41 wired Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="A software suite to predict/analyze mass spectrometric data on (bio)polymers."
+HOMEPAGE="http://massxpert.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/source/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/qt-svg:4[debug?]"
+DEPEND="${DEPEND}
+ doc? ( virtual/latex-base )"
+
+MASSXPERT_LANGS="fr"
+
+for L in ${MASSXPERT_LANGS}; do
+ IUSE="${IUSE} linguas_${L}"
+done
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ local langs=
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} ${MASSXPERT_LANGS}; then
+ langs="${langs} ${PN}_${lingua}.qm"
+ fi
+ done
+
+ sed -i -e "s/\(SET (massxpert_TRANSLATIONS \).*/\1${langs})/" \
+ gui/CMakeLists.txt || die "setting up translations failed"
+}
+
+src_configure() {
+ filter-ldflags -Wl,--as-needed --as-needed
+
+ mycmakeargs="
+ -DBUILD_PROGRAM=1
+ -DBUILD_DATA=1"
+ use doc && mycmakeargs="${mycmakeargs} -DBUILD_USERMANUAL=1"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon "gui/images/${PN}-icon-32.xpm" || die "installing icon failed"
+ dodoc TODO || die "dodoc failed"
+}