summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog7
-rw-r--r--sci-mathematics/pari/files/pari-2.3.3-alglin.patch17
-rw-r--r--sci-mathematics/pari/pari-2.1.7-r1.ebuild95
-rw-r--r--sci-mathematics/pari/pari-2.3.2-r1.ebuild114
-rw-r--r--sci-mathematics/pari/pari-2.3.2.ebuild112
-rw-r--r--sci-mathematics/pari/pari-2.3.4.ebuild152
-rw-r--r--sci-mathematics/pari/pari-2.3.5.ebuild8
7 files changed, 13 insertions, 492 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 55acc89d63f0..c179d3437849 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/pari
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.77 2010/05/09 17:26:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.78 2010/09/14 17:21:51 bicatali Exp $
+
+ 14 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -pari-2.1.7-r1.ebuild, -pari-2.3.2.ebuild, -pari-2.3.2-r1.ebuild,
+ -files/pari-2.3.3-alglin.patch, -pari-2.3.4.ebuild, pari-2.3.5.ebuild:
+ USE=-emacs was hanging in src_install. Patch by ulm, fixing bug #335898
09 May 2010; Raúl Porcel <armin76@gentoo.org> pari-2.3.4-r1.ebuild:
sparc stable
diff --git a/sci-mathematics/pari/files/pari-2.3.3-alglin.patch b/sci-mathematics/pari/files/pari-2.3.3-alglin.patch
deleted file mode 100644
index f0a9acc0fcb9..000000000000
--- a/sci-mathematics/pari/files/pari-2.3.3-alglin.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -Naur pari-2.3.3/src/basemath/alglin2.c pari-2.3.3.new/src/basemath/alglin2.c
---- pari-2.3.3/src/basemath/alglin2.c 2006-10-03 19:15:33.000000000 -0400
-+++ pari-2.3.3.new/src/basemath/alglin2.c 2008-05-06 21:05:06.000000000 -0400
-@@ -3082,11 +3082,9 @@
- for (i=h[j]; i; i--)
- {
- a = gcoeff(A,i,j);
-- if (!signe(a)) continue;
--
- k = c[i];
-- ZV_elem(a,gcoeff(A,i,k), A,B, j,k);
-- ZM_reduce(A,B, i,k);
-+ if (signe(a)) ZV_elem(a,gcoeff(A,i,k), A,B, j,k);
-+ ZM_reduce(A,B, i,k); /* ensure non-negative entries, even if a = 0 */
- if (low_stack(lim, stack_lim(av1,1)))
- {
- if (DEBUGMEM>1) pari_warn(warnmem,"hnfall[3], j = %ld", j);
diff --git a/sci-mathematics/pari/pari-2.1.7-r1.ebuild b/sci-mathematics/pari/pari-2.1.7-r1.ebuild
deleted file mode 100644
index e7e9efec6975..000000000000
--- a/sci-mathematics/pari/pari-2.1.7-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.7-r1.ebuild,v 1.13 2010/05/05 16:07:24 bicatali Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/OLD/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86"
-IUSE="doc emacs"
-
-DEPEND="doc? ( virtual/latex-base )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/docs.patch
-
- # remove exec stacks for x86; see bug #117434
- epatch "${FILESDIR}"/pari-non-exec-stack-x86-gentoo.patch
-}
-
-src_compile() {
- # Fix usage of toolchain
- tc-getAS; tc-getLD; tc-getCC; tc-getCXX
-
- # Special handling for sparc
- local myhost
- [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
- || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
- einfo "Building for ${myhost}"
-
- # need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
-
- # fix up build scripts to get rid of insecure RUNPATHS
- # see bug #117434
- sed -e "s|\$runpathprefix \$TOP/\$objdir:\$tmp||" \
- -e "s|\$runpathprefix \$tmp||" -i config/Makefile.SH || \
- die "Failed to fix Makefile.SH"
- sed -e "s|-L\$libdir|-L./|" -i Configure || \
- die "Failed to fix Configure"
-
- ./Configure \
- --host=${myhost} \
- --prefix=/usr \
- --miscdir=/usr/share/doc/${PF} \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./configure failed"
- addwrite "/var/lib/texmf"
- addwrite "/usr/share/texmf"
- addwrite "/var/cache/fonts"
-
- if use hppa
- then
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- fi
-
- # Shared libraries should be PIC on ALL architectures.
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
- # Fixes BUG #49583
- einfo "Building shared library..."
- cd Olinux-* || die "Bad directory. File a BUG!"
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
-
- einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
-
- use doc || rm -rf doc/*.tex
- use doc && emake doc
-}
-
-src_test() {
- ebegin "Testing pari kernel"
- make CFLAGS="-Wl,-lpari" test-kernel > /dev/null
- eend $?
-}
-
-src_install() {
- make DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || die
- if use emacs; then
- insinto /usr/share/emacs/site-lisp
- doins emacs/pari.el
- fi
- dodoc AUTHORS Announce.2.1 CHANGES README TODO
-}
diff --git a/sci-mathematics/pari/pari-2.3.2-r1.ebuild b/sci-mathematics/pari/pari-2.3.2-r1.ebuild
deleted file mode 100644
index 791c539f7aab..000000000000
--- a/sci-mathematics/pari/pari-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2-r1.ebuild,v 1.13 2008/08/27 20:04:42 markusle Exp $
-
-inherit elisp-common eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="A software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 hppa ~mips ppc ppc64 ~sparc ~x86"
-IUSE="doc emacs X"
-
-DEPEND="doc? ( virtual/latex-base )
- sys-libs/readline
- X? ( x11-libs/libX11 )
- emacs? ( virtual/emacs )"
-SITEFILE=50${PN}-gentoo.el
-
-get_compile_dir() {
- pushd "${S}/config" >& /dev/null
- local fastread=yes
- source ./get_archos
- popd >& /dev/null
- echo "O${osname}-${arch}"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/"${P}-strip.patch
- epatch "${FILESDIR}/"${P}-ppc-powerpc-arch-fix.patch
-
- # disable default building of docs during install
- sed -e "s:install-doc install-examples:install-examples:" \
- -i config/Makefile.SH || die "Failed to fix makefile"
-}
-
-src_compile() {
- #need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
-
- ./Configure \
- --prefix=/usr \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./Configure failed"
-
- if use hppa; then
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- fi
-
- # Shared libraries should be PIC on ALL architectures.
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
- # Fixes BUG #49583
- local installdir=$(get_compile_dir)
- einfo "Building shared library..."
- cd "${installdir}" || die "Bad directory. File a BUG!"
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
-
- einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
-
- if use doc; then
- cd "${S}"
- emake docpdf || die "Failed to generate docs"
- fi
-
- if use emacs; then
- cd "${S}/emacs"
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- make test-kernel
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || \
- die "Install failed"
-
- if use emacs; then
- elisp-install ${PN} emacs/*.el emacs/*.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- dodoc AUTHORS Announce.2.1 CHANGES README TODO NEW
- if use doc; then
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install-doc \
- || die "Failed to install docs"
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die "Failed to install pdf docs"
- fi
-
- #remove superfluous doc directory
- rm -fr "${D}/usr/share/${P}/doc" || \
- die "Failed to clean up doc directory"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/pari/pari-2.3.2.ebuild b/sci-mathematics/pari/pari-2.3.2.ebuild
deleted file mode 100644
index 8e53abc75c77..000000000000
--- a/sci-mathematics/pari/pari-2.3.2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2.ebuild,v 1.12 2008/08/27 20:04:42 markusle Exp $
-
-inherit elisp-common eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="A software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ~mips ~ppc sparc x86"
-IUSE="doc emacs X"
-
-DEPEND="doc? ( virtual/latex-base )
- sys-libs/readline
- X? ( x11-libs/libX11 )
- emacs? ( virtual/emacs )"
-SITEFILE=50${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # disable default building of docs during install
- sed -e "s:install-doc install-examples:install-examples:" \
- -i config/Makefile.SH || die "Failed to fix makefile"
-}
-
-src_compile() {
- # Special handling for sparc
- local myhost
- [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparcv9-linux" \
- || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
- einfo "Building for ${myhost}"
-
- #need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
-
- ./Configure \
- --host=${myhost} \
- --prefix=/usr \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./configure failed"
-
- if use hppa
- then
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- fi
-
- # Shared libraries should be PIC on ALL architectures.
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
- # Fixes BUG #49583
- einfo "Building shared library..."
- cd Olinux-* || die "Bad directory. File a BUG!"
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
-
- einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
-
- if use doc; then
- cd "${S}"
- emake docpdf || die "Failed to generate docs"
- fi
-
- if use emacs; then
- cd "${S}/emacs"
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- ebegin "Testing pari kernel"
- make test-kernel
- eend $?
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || \
- die "Install failed"
-
- if use emacs; then
- elisp-install ${PN} emacs/*.el emacs/*.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- dodoc AUTHORS Announce.2.1 CHANGES README TODO NEW
- if use doc; then
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install-doc \
- || die "Failed to install docs"
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die "Failed to install pdf docs"
- fi
-
- #remove superfluous doc directory
- rm -fr "${D}/usr/share/${P}/doc" || \
- die "Failed to clean up doc directory"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/pari/pari-2.3.4.ebuild b/sci-mathematics/pari/pari-2.3.4.ebuild
deleted file mode 100644
index e86aa0397d0a..000000000000
--- a/sci-mathematics/pari/pari-2.3.4.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.4.ebuild,v 1.1 2009/01/15 17:19:08 bicatali Exp $
-
-EAPI=2
-inherit elisp-common eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="A software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/${PN}/unix/${P}.tar.gz
- elliptic? ( http://pari.math.u-bordeaux.fr/pub/${PN}/packages/elldata.tgz )
- galois? ( http://pari.math.u-bordeaux.fr/pub/${PN}/packages/galdata.tgz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc emacs X elliptic galois gmp static"
-
-RDEPEND="sys-libs/readline
- X? ( x11-libs/libX11 )
- emacs? ( virtual/emacs )
- gmp? ( dev-libs/gmp )"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-SITEFILE=50${PN}-gentoo.el
-
-get_compile_dir() {
- pushd "${S}/config" >& /dev/null
- local fastread=yes
- source ./get_archos
- popd >& /dev/null
- echo "O${osname}-${arch}"
-}
-
-src_prepare() {
- # move data into place
- if ( use galois || use elliptic ); then
- mv "${WORKDIR}"/data "${S}" \
- || die "failed to move data"
- fi
-
- epatch "${FILESDIR}/"${PN}-2.3.2-strip.patch
- epatch "${FILESDIR}/"${PN}-2.3.2-ppc-powerpc-arch-fix.patch
-
- # disable default building of docs during install
- sed -e "s:install-doc install-examples:install-examples:" \
- -i config/Makefile.SH || die "Failed to fix makefile"
- # propagate ldflags
- sed -i \
- -e 's/-shared $extra/-shared $extra \\$(LDFLAGS)/' \
- config/get_dlld || die
-}
-
-src_configure() {
- #need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
-
- local myconf="--with-readline"
- use gmp && myconf="${myconf} --kernel=gmp"
-
- ./Configure \
- --prefix=/usr \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 \
- ${myconf} \
- || die "./Configure failed"
-}
-
-src_compile() {
- if use hppa; then
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- fi
- local installdir=$(get_compile_dir)
- cd "${installdir}" || die "Bad directory. File a BUG!"
-
- einfo "Building shared library..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn \
- || die "Building shared library failed!"
-
- if use static; then
- einfo "Building static library..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" lib-sta \
- || die "Building static library failed!"
- fi
-
- einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp \
- || die "Building executables failed!"
-
- if use doc; then
- cd "${S}"
- # To prevent sandbox violations by metafont
- VARTEXFONTS="${T}"/fonts emake docpdf \
- || die "Failed to generate docs"
- fi
-
- if use emacs; then
- cd "${S}/emacs"
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- emake test-kernel || die
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install \
- || die "Install failed"
-
- if use emacs; then
- elisp-install ${PN} emacs/*.el emacs/*.elc \
- || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- dodoc AUTHORS Announce.2.1 CHANGES README NEW
- if use doc; then
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install-doc \
- || die "Failed to install docs"
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die "Failed to install pdf docs"
- fi
-
- if (use galois || use elliptic); then
- emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install-data \
- || die "Failed to install data files"
- fi
-
- if use static; then
- emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install-lib-sta || \
- die "Install of static library failed"
- fi
-
- #remove superfluous doc directory
- rm -fr "${D}/usr/share/${P}/doc" || \
- die "Failed to clean up doc directory"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/pari/pari-2.3.5.ebuild b/sci-mathematics/pari/pari-2.3.5.ebuild
index 8d7099d72361..ec5cc77d2e0b 100644
--- a/sci-mathematics/pari/pari-2.3.5.ebuild
+++ b/sci-mathematics/pari/pari-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.5.ebuild,v 1.1 2010/05/04 21:56:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.5.ebuild,v 1.2 2010/09/14 17:21:51 bicatali Exp $
EAPI=2
inherit elisp-common eutils flag-o-matic toolchain-funcs
@@ -61,6 +61,12 @@ src_prepare() {
-e 's:"xdvi":"xdg-open":' \
-e 's:xdvi -paper 29.7x21cm:xdg-open:' \
doc/gphelp.in || die "Failed to fix doc dir"
+
+ if ! use emacs; then
+ # disable emacs support
+ sed -i -e '/^list=/s/emacs//' Configure \
+ || die "Failed to edit Configure"
+ fi
}
src_configure() {