summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/discover/discover-1.5-r1.ebuild')
-rw-r--r--sys-apps/discover/discover-1.5-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/discover/discover-1.5-r1.ebuild b/sys-apps/discover/discover-1.5-r1.ebuild
new file mode 100644
index 000000000000..6ae540c86443
--- /dev/null
+++ b/sys-apps/discover/discover-1.5-r1.ebuild
@@ -0,0 +1,53 @@
+#
+# (C) 2002 The TelemetryBox Corporation. http://telemetrybox.biz
+# Christoph Lameter, <christoph@lameter.com>, July 15, 2002
+#
+# Released under the GPL
+#
+# -r1 provide gentoo discover script. Create missing /var/lib/discover
+# directory
+DESCRIPTION="Discover hardware and load the appropriate drivers for that hardware."
+
+LONGDESC="
+ Discover is a hardware identification system based on the libdiscover1
+ library. Discover provides a flexible interface that programs can use to
+ report a wide range of information about the hardware that is installed on a
+ Linux system. In addition to reporting information, discover includes
+ support for doing hardware detection at boot time. Detection occurs in two
+ stages: The first stage, which runs from an initial ramdisk (initrd), loads
+ just the drivers needed to mount the root file system, and the second stage
+ loads the rest (ethernet cards, sound cards, etc.)."
+
+HOMEPAGE="http://www.progeny.com/discover"
+
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/d/discover/discover_1.5-1.tar.gz"
+
+LICENSE="GPL"
+SLOT="1"
+KEYWORDS="x86 ppc"
+
+DEPEND="bash"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+RDEPEND="home/discover-data"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die "configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ cp ${FILESDIR}/etc-init.d-discover ${D}/etc/init.d/discover
+ insinto /usr/share/discover
+ doins discover/linuxrc
+ dodoc BUGS AUTHORS ChangeLog NEWS README TODO ChangeLog.mandrake docs/ISA-Structure docs/PCI-Structure docs/Programming
+ insinto /var/lib/discover
+ prepallman
+}