summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/ChangeLog6
-rw-r--r--sys-apps/file/file-4.14.ebuild5
-rw-r--r--sys-apps/file/files/file-4.14-gcc2.patch13
3 files changed, 22 insertions, 2 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index c8e353833a31..9cc320ef44b0 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/file
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.83 2005/07/20 12:21:13 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.84 2005/07/24 12:57:43 azarah Exp $
+
+ 24 Jul 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/file-4.14-gcc2.patch, file-4.14.ebuild:
+ Fix building with gcc2.
20 Jul 2005; Markus Rothe <corsair@gentoo.org> file-4.13.ebuild:
Stable on ppc64
diff --git a/sys-apps/file/file-4.14.ebuild b/sys-apps/file/file-4.14.ebuild
index 95e0e568a614..7f6bd2ad4839 100644
--- a/sys-apps/file/file-4.14.ebuild
+++ b/sys-apps/file/file-4.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.14.ebuild,v 1.1 2005/07/17 11:30:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.14.ebuild,v 1.2 2005/07/24 12:57:43 azarah Exp $
inherit flag-o-matic eutils distutils libtool toolchain-funcs
@@ -30,6 +30,9 @@ src_unpack() {
# libtool don't barf all over the place when trying to parse it.
epatch "${FILESDIR}"/${PN}-4.xx-mips-gentoo.patch
+ # Fix building with gcc2
+ epatch "${FILESDIR}"/${P}-gcc2.patch
+
# The build process tries to run the compiled file ... not a good
# thing if file was cross compiled ;)
tc-is-cross-compiler && epatch "${FILESDIR}"/${PN}-4.13-cross-compile.patch
diff --git a/sys-apps/file/files/file-4.14-gcc2.patch b/sys-apps/file/files/file-4.14-gcc2.patch
new file mode 100644
index 000000000000..f5d5774b9668
--- /dev/null
+++ b/sys-apps/file/files/file-4.14-gcc2.patch
@@ -0,0 +1,13 @@
+--- file-4.14/src/readelf.c 2005-07-24 14:11:30 +0200
++++ file-4.14.az/src/readelf.c 2005-07-24 14:11:46 +0200
+@@ -490,9 +490,9 @@
+
+ if (namesz == 10 && strcmp((char *)&nbuf[noff], "DragonFly") == 0 &&
+ nh_type == NT_DRAGONFLY_VERSION && descsz == 4) {
++ uint32_t desc;
+ if (file_printf(ms, ", for DragonFly") == -1)
+ return size;
+- uint32_t desc;
+ (void)memcpy(&desc, &nbuf[doff], sizeof(desc));
+ desc = getu32(swap, desc);
+ if (file_printf(ms, " %d.%d.%d", desc / 100000,