summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/ChangeLog8
-rw-r--r--sys-apps/sed/sed-4.2.1.ebuild67
-rw-r--r--sys-apps/sed/sed-4.2.ebuild65
3 files changed, 6 insertions, 134 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index c2cea77e0306..93bb9f33418c 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sed
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.127 2014/02/08 13:24:00 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.128 2015/07/21 21:16:08 mrueg Exp $
+
+ 21 Jul 2015; Manuel Rüger <mrueg@gentoo.org> -sed-4.2.1.ebuild,
+ -sed-4.2.ebuild:
+ Remove old.
08 Feb 2014; Mike Frysinger <vapier@gentoo.org> -files/dos2unix,
-files/unix2dos, sed-4.2.1-r1.ebuild, sed-4.2.1.ebuild, sed-4.2.2.ebuild,
diff --git a/sys-apps/sed/sed-4.2.1.ebuild b/sys-apps/sed/sed-4.2.1.ebuild
deleted file mode 100644
index 9df517b73f75..000000000000
--- a/sys-apps/sed/sed-4.2.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.2.1.ebuild,v 1.12 2014/02/08 13:24:00 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="acl nls selinux static"
-
-RDEPEND="nls? ( virtual/libintl )
- acl? ( virtual/acl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786
- export NO_SYS_SED=""
- if ! type -p sed > /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- make clean || die "couldnt clean"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
- # don't use sed here if we have to recover a broken host sed
-}
-
-src_compile() {
- src_bootstrap_sed
- # this has to be after the bootstrap portion
- sed -i \
- -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
- doc/Makefile.in || die "sed html doc"
-
- local myconf= bindir=/bin
- if ! use userland_GNU ; then
- myconf="--program-prefix=g"
- bindir=/usr/bin
- fi
-
- export ac_cv_search_setfilecon=$(usex selinux -lselinux)
- export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
- use static && append-ldflags -static
- econf \
- --bindir=${bindir} \
- $(use_enable acl) \
- $(use_enable nls) \
- ${myconf}
- emake || die "build failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Install failed"
- dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
-}
diff --git a/sys-apps/sed/sed-4.2.ebuild b/sys-apps/sed/sed-4.2.ebuild
deleted file mode 100644
index 96e1f187c3d1..000000000000
--- a/sys-apps/sed/sed-4.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.2.ebuild,v 1.13 2014/02/08 13:24:00 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="acl nls static"
-
-RDEPEND="nls? ( virtual/libintl )
- acl? ( virtual/acl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786
- export NO_SYS_SED=""
- if ! type -p sed > /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- make clean || die "couldnt clean"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
- # don't use sed here if we have to recover a broken host sed
-}
-
-src_compile() {
- src_bootstrap_sed
- # this has to be after the bootstrap portion
- sed -i \
- -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
- doc/Makefile.in || die "sed html doc"
-
- local myconf= bindir=/bin
- if ! use userland_GNU ; then
- myconf="--program-prefix=g"
- bindir=/usr/bin
- fi
-
- use static && append-ldflags -static
- econf \
- --bindir=${bindir} \
- $(use_enable acl) \
- $(use_enable nls) \
- ${myconf}
- emake || die "build failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Install failed"
- dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
-}