summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.7.2.ebuild')
-rw-r--r--sys-devel/automake/automake-1.7.2.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/sys-devel/automake/automake-1.7.2.ebuild b/sys-devel/automake/automake-1.7.2.ebuild
index 9bebb5a4660c..7d9f4bc583e9 100644
--- a/sys-devel/automake/automake-1.7.2.ebuild
+++ b/sys-devel/automake/automake-1.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.2.ebuild,v 1.8 2003/09/02 19:16:48 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.2.ebuild,v 1.9 2003/09/06 08:10:38 msterret Exp $
IUSE=""
@@ -111,7 +111,7 @@ src_compile() {
# so 'ac-wrapper.pl' do not detect that it should use
# autoconf-2.5x
export WANT_AUTOCONF_2_5=1
-
+
cd ${OLD16_S}
perl -pi -e 's:setfilename automake.info:setfilename automake16.info:' \
@@ -120,12 +120,12 @@ src_compile() {
automake.texi
perl -pi -e 's|\* aclocal:|\* aclocal v1.6:|' automake.texi
perl -pi -e 's:\(automake\):\(automake16\):' automake.texi
-
+
./configure --prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--target=${CHOST} || die
-
+
emake || die
#
@@ -140,12 +140,12 @@ src_compile() {
automake.texi
perl -pi -e 's|\* aclocal:|\* aclocal v1.5:|' automake.texi
perl -pi -e 's:\(automake\):\(automake15\):' automake.texi
-
+
./configure --prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--target=${CHOST} || die
-
+
emake || die
unset WANT_AUTOCONF_2_5
@@ -160,12 +160,12 @@ src_compile() {
perl -pi -e 's:GNU admin:GNU programming tools:' automake.texi
# perl -pi -e 's|\* automake: \(automake\)|\* Automake: \(automake\)|' \
# automake.texi
-
+
./configure --prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--target=${CHOST} || die
-
+
emake || die
}
@@ -173,13 +173,13 @@ src_compile() {
# use the correct directories, and also adds the normal
# /usr/share/aclocal for aclocal to include.
fix_bins() {
-
+
for x in aclocal automake
do
perl -pi -e "s:share/automake\":share/automake-${1}\":g" ${x}
perl -pi -e "s:share/aclocal\":share/aclocal-${1}\":g" ${x}
done
-
+
# add "/usr/share/aclocal" to m4 search patch
cp aclocal aclocal.orig
sed -e '/&scan_m4_files (@dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
@@ -235,7 +235,7 @@ src_install() {
cd ${OLD16_S}
# not needed for 1.6.3
# fix_bins ${NEW_PV}
-
+
make DESTDIR=${D} \
install || die
@@ -256,7 +256,7 @@ src_install() {
cd ${OLD15_S}
fix_bins ${OLD15_PV}
-
+
make DESTDIR=${D} \
pkgdatadir=/usr/share/automake-${OLD15_PV} \
m4datadir=/usr/share/aclocal-${OLD15_PV} \
@@ -282,7 +282,7 @@ src_install() {
# Ignore duplicates like automake-1.5 and 1.6
patch -p0 <${FILESDIR}/${PN}-1.4_p5-ignore-duplicates.patch || die
-
+
make DESTDIR=${D} \
pkgdatadir=/usr/share/automake-1.4 \
m4datadir=/usr/share/aclocal-1.4 \
@@ -299,7 +299,7 @@ src_install() {
#
# ************ misc stuff ****************
-
+
# Some packages needs a /usr/share/automake directory
dosym automake-1.4 /usr/share/automake
@@ -309,7 +309,7 @@ src_install() {
}
pkg_preinst() {
-
+
# remove these to make sure symlinks install properly if old versions
# was binaries
for x in automake aclocal