summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-1.2.4.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.2.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.2.4.ebuild b/sys-devel/gcc-config/gcc-config-1.2.4.ebuild
deleted file mode 100644
index 82110871c08b..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.2.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.2.4.ebuild,v 1.1 2002/12/16 18:45:51 azarah Exp $
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utility to change the gcc compiler being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
-
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
-}
-
-pkg_postinst() {
-
- # Do we have a valid multi ver setup ?
- if ${ROOT}/usr/sbin/gcc-config --get-current-profile > /dev/null
- then
- # /usr/bin/cpp borks things if present ...
- if [ -L ${ROOT}/usr/bin/cpp -o -f ${ROOT}/usr/bin/cpp ]
- then
- rm -f ${ROOT}/usr/bin/cpp
- fi
-
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- if [ -L ${ROOT}/usr/include/g++ ]
- then
- rm -f ${ROOT}/usr/include/g++
- fi
- if [ -L ${ROOT}/usr/include/g++-v3 ]
- then
- rm -f ${ROOT}/usr/include/g++-v3
- fi
-
- if [ ${ROOT} = "/" ]
- then
- /usr/sbin/gcc-config $(/usr/sbin/gcc-config --get-current-profile)
- fi
- fi
-}
-