summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/convertfs/convertfs-20020318-r1.ebuild')
-rw-r--r--sys-fs/convertfs/convertfs-20020318-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/convertfs/convertfs-20020318-r1.ebuild b/sys-fs/convertfs/convertfs-20020318-r1.ebuild
new file mode 100644
index 000000000000..21b9ad663e21
--- /dev/null
+++ b/sys-fs/convertfs/convertfs-20020318-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/convertfs/convertfs-20020318-r1.ebuild,v 1.1 2004/06/27 09:48:35 twp Exp $
+
+DESCRIPTION="A tool to convert filesystems in-place"
+HOMEPAGE="http://tzukanov.narod.ru/convertfs/"
+SRC_URI="http://tzukanov.narod.ru/convertfs/convertfs-18mar2002.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="virtual/glibc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/convertfs-20020318-convertfs-paths.patch
+ cd ${S}
+ sed -i Makefile -e "s/^\(CFLAGS=\).*\$/\1${CFLAGS}/"
+}
+
+src_compile() {
+ emake devclone devremap prepindex || die
+}
+
+src_install() {
+ into /
+ dosbin convertfs_dumb devclone devremap prepindex contrib/convertfs
+}
+
+pkg_postinst() {
+ ewarn "This tool is HIGHLY DANGEROUS. Read the homepage before using it!"
+ ewarn " ${HOMEPAGE}"
+ ewarn "You have been warned!"
+}