summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/detect')
-rw-r--r--sys-libs/detect/detect-0.9.72.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/sys-libs/detect/detect-0.9.72.ebuild b/sys-libs/detect/detect-0.9.72.ebuild
index 64a847722af9..e5ac476bf7dd 100644
--- a/sys-libs/detect/detect-0.9.72.ebuild
+++ b/sys-libs/detect/detect-0.9.72.ebuild
@@ -1,38 +1,41 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/detect/detect-0.9.72.ebuild,v 1.8 2004/08/24 04:09:09 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/detect/detect-0.9.72.ebuild,v 1.9 2004/10/10 02:31:27 vapier Exp $
-DESCRIPTION="Detect is a library for automatic hardware detection."
+inherit eutils
+
+DESCRIPTION="library for automatic hardware detection"
HOMEPAGE="http://www.mandrakelinux.com/harddrake/index.php"
SRC_URI="mirror://debian/pool/main/d/detect/${P//-/_}.orig.tar.gz
mirror://debian/pool/main/d/detect/${P//-/_}-6.1.diff.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+
DEPEND="virtual/libc"
+
S="${WORKDIR}/${PN}"
src_unpack() {
- unpack ${P//-/_}.orig.tar.gz
- cd $S
- gunzip -c ${DISTDIR}/${P//-/_}-6.1.diff.gz | patch -p1
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P//-/_}-6.1.diff
+ chmod a+rx configure config.sub config.guess
+ sed -i '/include.*genhd\.h/s:.*::' src/{detect.h,disk.c}
}
src_compile() {
- ./autogen.sh \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf --with-kernel-source="${ROOT}/usr" || die
emake || die
}
-src_install () {
- #make DESTDIR=${D} install || die
+src_install() {
make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
+ DESTDIR="${D}" \
+ localedir="${D}/usr/share/locale" \
+ gnulocaledir="${D}/usr/share/locale" \
install || die
}