summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.2.5-r7.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r7.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.2.5-r7.ebuild b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
index a87477ede2b4..4bcd24a579aa 100644
--- a/sys-libs/glibc/glibc-2.2.5-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.3 2002/08/15 06:03:58 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.4 2002/08/16 01:22:43 murphy Exp $
inherit flag-o-matic
filter-flags "-fomit-frame-pointer -malign-double"
@@ -107,6 +107,11 @@ src_unpack() {
# problems with gcc-3.1.1.
# (Azarah, 14 Jul 2002)
cd ${S}; patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311.patch || die
+
+ # Avoid "Error: illegal instruction" when compiling on sparc with gcc 3.1.1
+ if [ ${ARCH} == "sparc" -o ${ARCH} == "sparc64" ]; then
+ patch -p1 < ${FILESDIR}/glibc-2.2.5-gcc311-sparc.patch || die
+ fi
}
src_compile() {