summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/at/at-3.1.8-r12.ebuild')
-rw-r--r--sys-process/at/at-3.1.8-r12.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-process/at/at-3.1.8-r12.ebuild b/sys-process/at/at-3.1.8-r12.ebuild
new file mode 100644
index 000000000000..e2ab8e24bf96
--- /dev/null
+++ b/sys-process/at/at-3.1.8-r12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.8-r12.ebuild,v 1.1 2005/09/04 07:28:29 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="ftp://jurix.jura.uni-sb.de/pub/jurix/source/chroot/appl/at/"
+SRC_URI="http://ftp.debian.org/debian/pool/main/a/at/at_${PV}-11.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/flex-2.5.4a
+ >=sys-apps/portage-2.0.51"
+RDEPEND="virtual/mta"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/cron/atjobs at
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-more-deny.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-longuser.patch
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install IROOT="${D}" || die
+ touch "${D}"/var/spool/at/at{jobs,spool}/.SEQ
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ prepalldocs
+}