summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/pango/pango-1.0.4.ebuild')
-rw-r--r--x11-libs/pango/pango-1.0.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/x11-libs/pango/pango-1.0.4.ebuild b/x11-libs/pango/pango-1.0.4.ebuild
deleted file mode 100644
index 1308e259c779..000000000000
--- a/x11-libs/pango/pango-1.0.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.0.4.ebuild,v 1.1 2002/08/03 22:43:53 stroke Exp $
-
-
-inherit debug
-inherit libtool
-
-SLOT="1"
-KEYWORDS="x86"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Text rendering and Layout library"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
-HOMEPAGE="http://www.pango.org/"
-LICENSE="LGPL-2.1"
-
-RDEPEND="virtual/x11
- >=dev-libs/glib-2.0.6
- >=media-libs/freetype-2.0.9"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-
-src_compile() {
- elibtoolize
- local myconf
- use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --without-qt \
- --enable-debug || die
- # turn on debug again, glib dislikes not having it.
- emake || make || die "paralell make and serial make failed"
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
- rm ${D}/etc/pango/pango.modules
-
-
- dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO*
-}
-
-pkg_postinst() {
- pango-querymodules >/etc/pango/pango.modules
-}
-