summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog9
-rw-r--r--x11-libs/qscintilla/files/qscintilla-2.4-designer.patch29
-rw-r--r--x11-libs/qscintilla/qscintilla-2.6.1.ebuild70
-rw-r--r--x11-libs/qscintilla/qscintilla-2.7.ebuild (renamed from x11-libs/qscintilla/qscintilla-2.5.1.ebuild)43
4 files changed, 32 insertions, 119 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index 5d253863673c..41302f6b1651 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qscintilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.80 2012/09/09 15:54:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.81 2012/12/10 12:27:22 pesa Exp $
+
+*qscintilla-2.7 (10 Dec 2012)
+
+ 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +qscintilla-2.7.ebuild,
+ -files/qscintilla-2.4-designer.patch, -qscintilla-2.5.1.ebuild,
+ -qscintilla-2.6.1.ebuild:
+ Version bump, remove old.
09 Sep 2012; Raúl Porcel <armin76@gentoo.org> qscintilla-2.6.2.ebuild:
alpha/ia64/sparc stable wrt #429042
diff --git a/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch b/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch
deleted file mode 100644
index b4e7d2210c0a..000000000000
--- a/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Naur QScintilla-gpl-2.4.orig/designer-Qt3/designer.pro QScintilla-gpl-2.4/designer-Qt3/designer.pro
---- QScintilla-gpl-2.4.orig/designer-Qt3/designer.pro 2009-06-07 21:55:35.000000000 +0200
-+++ QScintilla-gpl-2.4/designer-Qt3/designer.pro 2009-06-07 22:01:14.000000000 +0200
-@@ -3,10 +3,13 @@
-
- TEMPLATE = lib
- TARGET = qscintillaplugin
--DESTDIR = $(QTDIR)/plugins/designer
-
- CONFIG += qt warn_on release plugin
-
- SOURCES += qscintillaplugin.cpp
-
--LIBS += -lqscintilla2
-+target.path = $(QTDIR)/plugins/designer
-+INSTALLS += target
-+
-+INCLUDEPATH = ../Qt3
-+LIBS += -L../Qt3 -lqscintilla2
-diff -Naur QScintilla-gpl-2.4.orig/designer-Qt4/designer.pro QScintilla-gpl-2.4/designer-Qt4/designer.pro
---- QScintilla-gpl-2.4.orig/designer-Qt4/designer.pro 2009-06-07 21:55:35.000000000 +0200
-+++ QScintilla-gpl-2.4/designer-Qt4/designer.pro 2009-06-07 21:57:46.000000000 +0200
-@@ -12,4 +12,5 @@
- target.path = $$[QT_INSTALL_PLUGINS]/designer
- INSTALLS += target
-
--LIBS += -lqscintilla2
-+INCLUDEPATH = ../Qt4
-+LIBS += -L../Qt4 -lqscintilla2
diff --git a/x11-libs/qscintilla/qscintilla-2.6.1.ebuild b/x11-libs/qscintilla/qscintilla-2.6.1.ebuild
deleted file mode 100644
index 2fc20f1a388b..000000000000
--- a/x11-libs/qscintilla/qscintilla-2.6.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.6.1.ebuild,v 1.5 2012/07/08 18:36:21 armin76 Exp $
-
-EAPI="3"
-
-inherit qt4-r2
-
-MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
-
-DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ~ppc ~ppc64 sparc x86"
-IUSE="doc python"
-
-DEPEND="x11-libs/qt-gui:4"
-RDEPEND="${DEPEND}"
-PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=("${FILESDIR}/${PN}-2.4-designer.patch")
-
-src_configure() {
- pushd Qt4 > /dev/null
- einfo "Configuration of qscintilla"
- eqmake4 qscintilla.pro
- popd > /dev/null
-
- pushd designer-Qt4 > /dev/null
- einfo "Configuration of designer plugin"
- eqmake4 designer.pro
- popd > /dev/null
-}
-
-src_compile() {
- pushd Qt4 > /dev/null
- einfo "Building of qscintilla"
- emake || die "Building of qscintilla failed"
- popd > /dev/null
-
- pushd designer-Qt4 > /dev/null
- einfo "Building of designer plugin"
- emake || die "Building of designer plugin failed"
- popd > /dev/null
-}
-
-src_install() {
- pushd Qt4 > /dev/null
- einfo "Installation of qscintilla"
- emake INSTALL_ROOT="${D}" install || die "Installation of qscintilla failed"
- popd > /dev/null
-
- pushd designer-Qt4 > /dev/null
- einfo "Installation of designer plugin"
- emake INSTALL_ROOT="${D}" install || die "Installation of designer plugin failed"
- popd > /dev/null
-
- dodoc NEWS || die "dodoc failed"
- if use doc; then
- einfo "Installation of documentation"
- dohtml doc/html-Qt4/* || die "dohtml failed"
- insinto /usr/share/doc/${PF}/Scintilla
- doins doc/Scintilla/* || die "doins failed"
- fi
-}
diff --git a/x11-libs/qscintilla/qscintilla-2.5.1.ebuild b/x11-libs/qscintilla/qscintilla-2.7.ebuild
index a393fdcf6fde..09a045fa7e0a 100644
--- a/x11-libs/qscintilla/qscintilla-2.5.1.ebuild
+++ b/x11-libs/qscintilla/qscintilla-2.7.ebuild
@@ -1,32 +1,37 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.5.1.ebuild,v 1.5 2012/03/25 18:05:49 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.7.ebuild,v 1.1 2012/12/10 12:27:22 pesa Exp $
-EAPI="3"
+EAPI=4
inherit qt4-r2
-MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+MY_P=QScintilla-gpl-${PV}
DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~sparc x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc python"
-DEPEND="x11-libs/qt-gui:4"
+DEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+"
RDEPEND="${DEPEND}"
PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
S=${WORKDIR}/${MY_P}
-PATCHES=("${FILESDIR}/${PN}-2.4-designer.patch")
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.2-designer.patch"
+)
src_configure() {
- pushd Qt4 > /dev/null
+ pushd Qt4Qt5 > /dev/null
einfo "Configuration of qscintilla"
eqmake4 qscintilla.pro
popd > /dev/null
@@ -38,33 +43,33 @@ src_configure() {
}
src_compile() {
- pushd Qt4 > /dev/null
+ pushd Qt4Qt5 > /dev/null
einfo "Building of qscintilla"
- emake || die "Building of qscintilla failed"
+ emake
popd > /dev/null
pushd designer-Qt4 > /dev/null
einfo "Building of designer plugin"
- emake || die "Building of designer plugin failed"
+ emake
popd > /dev/null
}
src_install() {
- pushd Qt4 > /dev/null
+ pushd Qt4Qt5 > /dev/null
einfo "Installation of qscintilla"
- emake INSTALL_ROOT="${D}" install || die "Installation of qscintilla failed"
+ emake INSTALL_ROOT="${D}" install
popd > /dev/null
pushd designer-Qt4 > /dev/null
einfo "Installation of designer plugin"
- emake INSTALL_ROOT="${D}" install || die "Installation of designer plugin failed"
+ emake INSTALL_ROOT="${D}" install
popd > /dev/null
- dodoc NEWS || die "dodoc failed"
+ dodoc NEWS
+
if use doc; then
- einfo "Installation of documentation"
- dohtml doc/html-Qt4/* || die "dohtml failed"
- insinto /usr/share/doc/${PF}/Scintilla
- doins doc/Scintilla/* || die "doins failed"
+ dohtml doc/html-Qt4Qt5/*
+ insinto /usr/share/doc/${PF}
+ doins -r doc/Scintilla
fi
}