summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xforms/xforms-1.0.ebuild')
-rw-r--r--x11-libs/xforms/xforms-1.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11-libs/xforms/xforms-1.0.ebuild b/x11-libs/xforms/xforms-1.0.ebuild
index 2dfa563852f1..0825ae104f61 100644
--- a/x11-libs/xforms/xforms-1.0.ebuild
+++ b/x11-libs/xforms/xforms-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0.ebuild,v 1.5 2004/02/09 09:04:41 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0.ebuild,v 1.6 2004/02/29 15:04:38 aliz Exp $
S=${WORKDIR}/${P}-release
DESCRIPTION="A graphical user interface toolkit for X"
@@ -21,20 +21,17 @@ src_unpack() {
cd ${WORKDIR}/${P}-release
# use custom CFLAGS
- cp Imakefile Imakefile.orig
- sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
- -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile.orig > Imakefile
+ sed -i -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile
}
src_compile() {
xmkmf -a
- cp Makefile Makefile.orig
- sed -e s/'demos$'// Makefile.orig > Makefile
+ sed -i -e s/'demos$'// Makefile
# use custom CFLAGS
- cp Makefile Makefile.orig
- sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
- -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Makefile.orig > Makefile
+ sed -i -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Makefile
make || die
}