summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/pypanel/pypanel-1.1.ebuild')
-rw-r--r--x11-misc/pypanel/pypanel-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/pypanel/pypanel-1.1.ebuild b/x11-misc/pypanel/pypanel-1.1.ebuild
new file mode 100644
index 000000000000..b4ea52224a0b
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/pypanel-1.1.ebuild,v 1.1 2004/03/06 18:46:54 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="PyPanel is a lightweight panel/taskbar for X11 window managers."
+HOMEPAGE="http://pypanel.sourceforge.net"
+SRC_URI="mirror://sourceforge/pypanel/PyPanel-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=">=x11-base/xfree-4.3.0-r2
+ >=dev-lang/python-2.2.3-r1
+ >=dev-python/python-xlib-0.12"
+S="${WORKDIR}/PyPanel-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Removing offensive material
+ sed -i -e "s/%D %I:%M %p/%Y-%m-%d %H:%M/" pypanelrc
+}
+
+src_install() {
+ distutils_src_install
+ ewarn "If you previously ran 0.8, remove ~/.pypanelrc before starting 1.1!"
+}