From d5dcbd3f756fc60b116a0fc77b207585581d9f23 Mon Sep 17 00:00:00 2001
From: Matthew Kennedy <mkennedy@gentoo.org>
Date: Fri, 31 May 2002 23:42:05 +0000
Subject: Back to gpm-1.19.6

---
 app-editors/xemacs/ChangeLog                     |   9 +-
 app-editors/xemacs/files/digest-xemacs-21.4.8-r1 |   4 +
 app-editors/xemacs/xemacs-21.4.8-r1.ebuild       | 143 +++++++++++++++++++++++
 3 files changed, 155 insertions(+), 1 deletion(-)
 create mode 100644 app-editors/xemacs/files/digest-xemacs-21.4.8-r1
 create mode 100644 app-editors/xemacs/xemacs-21.4.8-r1.ebuild

(limited to 'app-editors/xemacs')

diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index f35d8b03820a..9e5a0ee0fd2e 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for app-editors/xemacs
 # Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.8 2002/05/19 19:16:30 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.9 2002/05/31 23:42:05 mkennedy Exp $
+
+*xemacs-21.4.8 (21 May 2002)
+
+  31 May 2002; Matthew Kennedy <mkennedy@gentoo.org> xemacs-21.4.8-r1.ebuild, 
+  files/digest-xemacs-21.4.8-r1, ChangeLog :
+
+  Back to gpm-1.19.6.
 
 *xemacs-21.4.8 (19 May 2002)
 
diff --git a/app-editors/xemacs/files/digest-xemacs-21.4.8-r1 b/app-editors/xemacs/files/digest-xemacs-21.4.8-r1
new file mode 100644
index 000000000000..510b903afe50
--- /dev/null
+++ b/app-editors/xemacs/files/digest-xemacs-21.4.8-r1
@@ -0,0 +1,4 @@
+MD5 8d111231c5ad7d2434f0a80de6de238d xemacs-21.4.8.tar.gz 10539644
+MD5 7622650d9c754337d7fd97c61ea8942b efs-1.28-pkg.tar.gz 370073
+MD5 f6e0bb7401bfce2d5a670c352b2376bb xemacs-base-1.61-pkg.tar.gz 457628
+MD5 5686febbb08c950ead2b4d0b1707c09e mule-base-1.39-pkg.tar.gz 443543
diff --git a/app-editors/xemacs/xemacs-21.4.8-r1.ebuild b/app-editors/xemacs/xemacs-21.4.8-r1.ebuild
new file mode 100644
index 000000000000..1bb4dfc4723a
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.4.8-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# Author: Geert Bevin <gbevin@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.8-r1.ebuild,v 1.1 2002/05/31 23:42:05 mkennedy Exp $
+
+# this is just TEMPORARY until we can get to the core of the problem
+SANDBOX_DISABLED="1"
+
+LICENSE="GPL-2"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system. This is the \"gamma\" release. Support for ncurses, and optional support for X via the lucid toolkit."
+EFS=1.28
+BASE=1.61
+MULE=1.39
+SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
+	http://ftp.xemacs.org/packages/efs-${EFS}-pkg.tar.gz
+	http://ftp.xemacs.org/packages/xemacs-base-${BASE}-pkg.tar.gz
+	http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
+HOMEPAGE="http://www.xemacs.org"
+
+SLOT=""
+
+RDEPEND="virtual/glibc
+	!virtual/xemacs
+
+	>=sys-libs/gdbm-1.8.0
+	>=sys-libs/zlib-1.1.4
+	>=dev-libs/openssl-0.9.6
+	>=media-libs/audiofile-0.2.3
+
+	gpm? ( >=sys-libs/gpm-1.19.6 )
+	postgres? ( >=dev-db/postgresql-7.2 )
+
+	nas? ( media-libs/nas )
+	esd? ( media-sound/esound )
+
+	mule? ()
+
+	X? ( virtual/x11 >=x11-libs/openmotif-2.1.30 )
+	xface? ( media-libs/compface )
+	tiff? ( media-libs/tiff )
+	png? ( =media-libs/libpng-1.2* )
+	jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+	>=sys-libs/ncurses-5.2"
+
+PROVIDE="virtual/xemacs"
+
+src_unpack() {
+	cd ${WORKDIR}
+	unpack ${P}.tar.gz
+	cd ${S}
+	patch -p0 <${FILESDIR}/emodules.info-21.4.8-gentoo.patch
+}
+
+src_compile() {
+	local myconf=""
+
+	if use X;
+	then
+		myconf="${myconf}
+			--with-x 
+			--with-xpm 
+			--with-dragndrop 
+			--with-gif=no"
+
+		use tiff && myconf="${myconf} --with-tiff" || 
+			myconf="${myconf} --without-tiff"
+		use png && mconf="${myconf} --with-png" || 
+			myconf="${myconf} --without-png"
+		use jpeg && myconf="${myconf} --with-jpeg" ||
+			myconf="${myconf} --without-jpeg"
+		use xface && myconf="${myconf} --with-xface" ||
+			myconf="${myconf} --without-xface"
+
+		myconf="${myconf} --with-dialogs=lucid"
+		myconf="${myconf} --with-widgets=lucid"
+		myconf="${myconf} --with-scrollbars=lucid"
+		myconf="${myconf} --with-menubars=lucid"
+	else
+		myconf="${myconf} 
+			--without-x 
+			--without-xpm 
+			--without-dragndrop 
+			--with-gif=no"
+	fi
+
+	use gpm	&& myconf="${myconf} --with-gpm" ||
+		myconf="${myconf} --without-gpm"
+	use postgres && myconf="${myconf} --with-postgresql" ||
+		myconf="${myconf} --without-postgresql"
+	use mule && myconf="${myconf} --with-mule" ||
+		myconf="${myconf} --without-mule"
+        
+	local soundconf="native"
+
+	use nas	&& soundconf="${soundconf},nas"
+	use esd	&& soundconf="${soundconf},esd"
+
+	myconf="${myconf} --with-sound=${soundconf}"
+
+	./configure ${myconf} \
+		--prefix=/usr \
+		--with-database=gnudbm \
+		--with-pop \
+		--with-ncurses \
+		--with-site-lisp=yes \
+		--package-path=/usr/lib/xemacs/xemacs-packages/ \
+		--with-msw=no \
+		|| die
+
+	emake || die
+}
+
+src_install() {                               
+	make prefix="${D}/usr" \
+		mandir="${D}/usr/share/man/man1" \
+		infodir="${D}/usr/share/info" \
+		install gzip-el || die
+        
+	# install base packages
+	dodir /usr/lib/xemacs/xemacs-packages/
+	cd ${D}/usr/lib/xemacs/xemacs-packages/
+	unpack efs-${EFS}-pkg.tar.gz
+	unpack xemacs-base-${BASE}-pkg.tar.gz
+	# (optionally) install mule base package 
+	if use mule;
+	then
+		dodir /usr/lib/xemacs/mule-packages
+		cd ${D}/usr/lib/xemacs/mule-packages/
+		unpack mule-base-${MULE}-pkg.tar.gz
+	fi
+        
+	# remove extraneous files
+	cd ${D}/usr/share/info
+	rm -f dir info.info texinfo* termcap*
+	cd ${S}
+	dodoc BUGS CHANGES-* COPYING ChangeLog GETTING* INSTALL PROBLEMS README*
+	dodoc ${FILESDIR}/README.Gentoo
+}
-- 
cgit v1.2.3-65-gdbad