From fb4f9e3fedfc84a06c8da533a70e8019fcb9c4a1 Mon Sep 17 00:00:00 2001
From: Michael Weber <xmw@gentoo.org>
Date: Thu, 20 Jun 2013 22:46:54 +0000
Subject: Update to new file structure and second shared lib. Add
 XF86XK_Forward and XF86XK_Back keys for Linux.

(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
---
 app-text/mupdf/ChangeLog                           |  9 ++++-
 app-text/mupdf/files/mupdf-9999-CFLAGS.patch       | 11 ++++++
 app-text/mupdf/files/mupdf-9999-buildsystem.patch  | 11 ------
 app-text/mupdf/files/mupdf-9999-forward_back.patch | 25 ++++++++++++
 .../mupdf/files/mupdf-9999-install-headers.patch   | 19 ----------
 app-text/mupdf/files/mupdf-9999-pkg-config.patch   |  7 ++--
 app-text/mupdf/files/mupdf-9999-zoom-2.patch       | 10 +++++
 app-text/mupdf/mupdf-9999.ebuild                   | 44 ++++++++++++----------
 8 files changed, 82 insertions(+), 54 deletions(-)
 create mode 100644 app-text/mupdf/files/mupdf-9999-CFLAGS.patch
 delete mode 100644 app-text/mupdf/files/mupdf-9999-buildsystem.patch
 create mode 100644 app-text/mupdf/files/mupdf-9999-forward_back.patch
 delete mode 100644 app-text/mupdf/files/mupdf-9999-install-headers.patch
 create mode 100644 app-text/mupdf/files/mupdf-9999-zoom-2.patch

(limited to 'app-text/mupdf')

diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index b222e3c2f801..173b6f99ce28 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for app-text/mupdf
 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.78 2013/06/20 09:11:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.79 2013/06/20 22:46:53 xmw Exp $
+
+  20 Jun 2013; Michael Weber <xmw@gentoo.org> +files/mupdf-9999-CFLAGS.patch,
+  +files/mupdf-9999-forward_back.patch, +files/mupdf-9999-zoom-2.patch,
+  -files/mupdf-9999-buildsystem.patch, -files/mupdf-9999-install-headers.patch,
+  files/mupdf-9999-pkg-config.patch, mupdf-9999.ebuild:
+  Update to new file structure and second shared lib. Add XF86XK_Forward and
+  XF86XK_Back keys for Linux.
 
   20 Jun 2013; Michael Weber <xmw@gentoo.org>
   +files/mupdf-9999-install-headers.patch, mupdf-9999.ebuild:
diff --git a/app-text/mupdf/files/mupdf-9999-CFLAGS.patch b/app-text/mupdf/files/mupdf-9999-CFLAGS.patch
new file mode 100644
index 000000000000..487c2128d12f
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-9999-CFLAGS.patch
@@ -0,0 +1,11 @@
+--- mupdf-1.0-source/Makerules
++++ mupdf-1.0-source/Makerules
+@@ -6,7 +6,7 @@
+ CFLAGS += -Wall
+ 
+ ifeq "$(build)" "debug"
+-CFLAGS += -pipe -g -DDEBUG
++CFLAGS += -DDEBUG
+ else ifeq "$(build)" "profile"
+ CFLAGS += -pipe -O2 -DNDEBUG -pg
+ LDFLAGS += -pg
diff --git a/app-text/mupdf/files/mupdf-9999-buildsystem.patch b/app-text/mupdf/files/mupdf-9999-buildsystem.patch
deleted file mode 100644
index 487c2128d12f..000000000000
--- a/app-text/mupdf/files/mupdf-9999-buildsystem.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mupdf-1.0-source/Makerules
-+++ mupdf-1.0-source/Makerules
-@@ -6,7 +6,7 @@
- CFLAGS += -Wall
- 
- ifeq "$(build)" "debug"
--CFLAGS += -pipe -g -DDEBUG
-+CFLAGS += -DDEBUG
- else ifeq "$(build)" "profile"
- CFLAGS += -pipe -O2 -DNDEBUG -pg
- LDFLAGS += -pg
diff --git a/app-text/mupdf/files/mupdf-9999-forward_back.patch b/app-text/mupdf/files/mupdf-9999-forward_back.patch
new file mode 100644
index 000000000000..35c6f1df1594
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-9999-forward_back.patch
@@ -0,0 +1,25 @@
+Add F86XK_Forward and XF86XK_Back for page switch by muhpdf@binkmail.com 
+on http://bugs.ghostscript.com/show_bug.cgi?id=693494
+
+--- mupdf-9999/platform/x11/x11_main.c
++++ mupdf-9999/platform/x11/x11_main.c
+@@ -5,6 +5,7 @@
+ #include <X11/Xatom.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>
++#include <X11/XF86keysym.h>
+ 
+ #include <sys/select.h>
+ #include <sys/time.h>
+@@ -836,9 +837,11 @@
+ 						break;
+ 
+ 					case XK_Page_Up:
++					case XF86XK_Back:
+ 						len = 1; buf[0] = ',';
+ 						break;
+ 					case XK_Page_Down:
++					case XF86XK_Forward:
+ 						len = 1; buf[0] = '.';
+ 						break;
+ 					}
diff --git a/app-text/mupdf/files/mupdf-9999-install-headers.patch b/app-text/mupdf/files/mupdf-9999-install-headers.patch
deleted file mode 100644
index 7c91abc9f2f9..000000000000
--- a/app-text/mupdf/files/mupdf-9999-install-headers.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-based on http://bugs.ghostscript.com/show_bug.cgi?id=694365&list_id=6717
-
---- mupdf-9999/Makefile
-+++ mupdf-9999/Makefile
-@@ -248,9 +248,12 @@
- mandir ?= $(prefix)/share/man
- 
- install: $(MUPDF_LIB) $(MUVIEW) $(MUDRAW) $(MUTOOL)
--	install -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(incdir) $(DESTDIR)$(mandir)/man1
-+	install -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(mandir)/man1
-+	install -d $(DESTDIR)$(incdir)/mupdf/{fitz,pdf}
- 	install $(MUPDF_LIB) $(DESTDIR)$(libdir)
--	install fitz/memento.h fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h image/muimage.h $(DESTDIR)$(incdir)
-+	install include/mupdf/*.h $(DESTDIR)$(incdir)/mupdf
-+	install include/mupdf/fitz/*.h $(DESTDIR)$(incdir)/mupdf/fitz
-+	install include/mupdf/pdf/*.h $(DESTDIR)$(incdir)/mupdf/pdf
- 	install $(MUVIEW) $(MUDRAW) $(MUTOOL) $(DESTDIR)$(bindir)
- 	install $(wildcard apps/man/*.1) $(DESTDIR)$(mandir)/man1
- 
diff --git a/app-text/mupdf/files/mupdf-9999-pkg-config.patch b/app-text/mupdf/files/mupdf-9999-pkg-config.patch
index 77d9533bc504..f0ccfb3e60ff 100644
--- a/app-text/mupdf/files/mupdf-9999-pkg-config.patch
+++ b/app-text/mupdf/files/mupdf-9999-pkg-config.patch
@@ -4,9 +4,9 @@ http://bugs.ghostscript.com/show_bug.cgi?id=694301
 openjpeg-2
 http://bugs.ghostscript.com/show_bug.cgi?id=693518
 
---- mupdf-9999/debian/mupdf.pc
-+++ mupdf-9999/debian/mupdf.pc
-@@ -4,9 +4,8 @@
+--- mupdf-9999/platform/debian/mupdf.pc
++++ mupdf-9999/platform/debian/mupdf.pc
+@@ -4,9 +4,9 @@
  includedir=${prefix}/include
  
  Name: mupdf
@@ -16,4 +16,5 @@ http://bugs.ghostscript.com/show_bug.cgi?id=693518
  Version: 0.5.0
  Libs: -L${libdir} -lmupdf
 -Libs.private: -lopenjpeg -ljbig2dec -ljpeg -lz -lm
++Libs.private: -lmupdf-js-none
  Cflags: -I${includedir}
diff --git a/app-text/mupdf/files/mupdf-9999-zoom-2.patch b/app-text/mupdf/files/mupdf-9999-zoom-2.patch
new file mode 100644
index 000000000000..2c9c8c9fd874
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-9999-zoom-2.patch
@@ -0,0 +1,10 @@
+--- mupdf-9999/platform/x11/pdfapp.c
++++ mupdf-9999/platform/x11/pdfapp.c
+@@ -866,6 +867,7 @@
+ 		break;
+ 
+ 	case ' ':
++	case 'F':
+ 		panto = DONT_PAN;
+ 		if (app->numberlen > 0)
+ 			app->pageno += atoi(app->number);
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
index 78c8004d1d4e..f6f1be148afe 100644
--- a/app-text/mupdf/mupdf-9999.ebuild
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.36 2013/06/20 09:11:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.37 2013/06/20 22:46:53 xmw Exp $
 
 EAPI=5
 
@@ -36,22 +36,25 @@ DEPEND="${RDEPEND}
 src_prepare() {
 	rm -rf thirdparty || die
 
+	[ -f source/fitz/draw-scale-simple.c ] && \
+		rm -f source/fitz/draw-scale.c
+
 	epatch \
-		"${FILESDIR}"/${P}-buildsystem.patch \
+		"${FILESDIR}"/${P}-CFLAGS.patch \
 		"${FILESDIR}"/${P}-openjpeg2.patch \
-		"${FILESDIR}"/${P}-pkg-config.patch \
-		"${FILESDIR}"/${P}-install-headers.patch
+		"${FILESDIR}"/${P}-pkg-config.patch
 
 	sed -e "/^libdir=/s:/lib:/$(get_libdir):" \
 		-e "/^prefix=/s:=.*:=${EROOR}/usr:" \
-		-i debian/mupdf.pc || die
+		-i platform/debian/mupdf.pc || die
 
 	use vanilla || epatch \
-		"${FILESDIR}"/${PN}-1.1_rc1-zoom-2.patch
+		"${FILESDIR}"/${P}-zoom-2.patch \
+		"${FILESDIR}"/${P}-forward_back.patch
 
 	#http://bugs.ghostscript.com/show_bug.cgi?id=693467
 	sed -e '/^Actions=/s:=.*:=View;:' \
-		-i debian/${PN}.desktop || die
+		-i platform/debian/${PN}.desktop || die
 
 	sed -e "\$aOS = Linux" \
 		-e "\$aCC = $(tc-getCC)" \
@@ -78,43 +81,44 @@ src_prepare() {
 	fi
 
 	my_soname=libmupdf.so.1.2
-	sed -e "\$a\$(MUPDF_LIB):" \
-		-e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
-		-e "/^MUPDF_LIB :=/s:=.*:= build/debug/${my_soname}:" \
+	my_soname_js_none=libmupdf-js-none.so.1.2
+	sed -e "\$a\$(MUPDF_LIB): \$(MUPDF_JS_NONE_LIB)" \
+		-e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(MUPDF_JS_NONE_LIB) \$(LIBS)" \
+		-e "/^MUPDF_LIB :=/s:=.*:= \$(OUT)/${my_soname}:" \
+		-e "\$a\$(MUPDF_JS_NONE_LIB):" \
+		-e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname_js_none} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
+		-e "/^MUPDF_JS_NONE_LIB :=/s:=.*:= \$(OUT)/${my_soname_js_none}:" \
 		-i Makefile || die
 }
 
 src_compile() {
 	emake XCFLAGS="-fpic"
 	use static-libs && \
-		emake -C "${S}"-static build/debug/libmupdf.a
+		emake -C "${S}"-static build/debug/libmupdf{,-js-none}.a
 	use static && \
 		emake -C "${S}"-static XLIBS="-static"
 }
 
 src_install() {
 	if use X ; then
-		domenu debian/mupdf.desktop
-		doicon debian/mupdf.xpm
+		domenu platform/debian/mupdf.desktop
+		doicon platform/debian/mupdf.xpm
 	else
-		rm apps/man/mupdf.1
+		rm docs/man/mupdf.1
 	fi
 
 	emake install
 	dosym ${my_soname} /usr/$(get_libdir)/libmupdf.so
 
 	use static-libs && \
-		dolib.a "${S}"-static/build/debug/libmupdf.a
+		dolib.a "${S}"-static/build/debug/libmupdf{,-js-none}.a
 	if use static ; then
 		dobin "${S}"-static/build/debug/mu{tool,draw}
 		use X && dobin "${S}"-static/build/debug/mupdf
 	fi
 
-	#insinto /usr/include
-	#doins pdf/mupdf-internal.h fitz/fitz-internal.h xps/muxps-internal.h
-
 	insinto /usr/$(get_libdir)/pkgconfig
-	doins debian/mupdf.pc
+	doins platform/debian/mupdf.pc
 
-	dodoc README doc/{example.c,overview.txt}
+	dodoc README docs/*.{txt,c}
 }
-- 
cgit v1.2.3-65-gdbad