aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-09-04 11:32:45 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-04 11:32:45 -0700
commitdaf0091f75f3a46da23edf73c48748a72f431203 (patch)
tree288a1f05a174dee623a571b787a577a34f20dbbf
parentAdd pycups and pygobject for system-config-printer. (diff)
downloaddberkholz-daf0091f75f3a46da23edf73c48748a72f431203.tar.gz
dberkholz-daf0091f75f3a46da23edf73c48748a72f431203.tar.bz2
dberkholz-daf0091f75f3a46da23edf73c48748a72f431203.zip
Add gentooification patches to system-config-*.
Stop using chkconfig, /etc/rc.d, and /sbin/service.
-rw-r--r--app-admin/system-config-date/Manifest8
-rw-r--r--app-admin/system-config-date/files/1.8.5-gentooify.patch38
-rw-r--r--app-admin/system-config-nfs/Manifest12
-rw-r--r--app-admin/system-config-nfs/files/1.3.19-gentooify.patch36
-rw-r--r--app-admin/system-config-nfs/system-config-nfs-1.3.19.ebuild8
-rw-r--r--app-admin/system-config-samba/Manifest12
-rw-r--r--app-admin/system-config-samba/files/1.2.35-gentooify.patch35
-rw-r--r--app-admin/system-config-samba/system-config-samba-1.2.35.ebuild8
8 files changed, 136 insertions, 21 deletions
diff --git a/app-admin/system-config-date/Manifest b/app-admin/system-config-date/Manifest
index c2512c6..30bafba 100644
--- a/app-admin/system-config-date/Manifest
+++ b/app-admin/system-config-date/Manifest
@@ -1,7 +1,7 @@
-AUX 1.8.5-gentooify.patch 1711 RMD160 90699e6d038c66ddaaa2c53cc35e259f0a289b54 SHA1 56a8ffec89a2fcbcdb39ee23e13a6c94104e7d55 SHA256 17ab9ddc17e2f389f187143f7ea84882ac12419497aadf61db0dfb18e913bab2
-MD5 1909b714689b041d6d2d28b0622201a2 files/1.8.5-gentooify.patch 1711
-RMD160 90699e6d038c66ddaaa2c53cc35e259f0a289b54 files/1.8.5-gentooify.patch 1711
-SHA256 17ab9ddc17e2f389f187143f7ea84882ac12419497aadf61db0dfb18e913bab2 files/1.8.5-gentooify.patch 1711
+AUX 1.8.5-gentooify.patch 2844 RMD160 b8e7c14b1bbabb6a40eb50d30cb280d1dfef389a SHA1 78556ad10962a417f60ab1a6b20e3c8cb3aa19c0 SHA256 207f078f6ff5b9aa2be40682f0089b9756a604e0b6ed8aa7706b9d4599606b1b
+MD5 daa68e22c6a8040a94f0a84806254455 files/1.8.5-gentooify.patch 2844
+RMD160 b8e7c14b1bbabb6a40eb50d30cb280d1dfef389a files/1.8.5-gentooify.patch 2844
+SHA256 207f078f6ff5b9aa2be40682f0089b9756a604e0b6ed8aa7706b9d4599606b1b files/1.8.5-gentooify.patch 2844
DIST system-config-date-1.8.5-1.src.rpm 592767 RMD160 302c14af813cd7a62a1c1027ce29722646ee921d SHA1 6abcd3efc7cc9276cfad03d218f8750e505f2e93 SHA256 4386526d059b8dda05377423a9d81e746a95d203511c7c2a4c257664621e9468
EBUILD system-config-date-1.8.5.ebuild 1011 RMD160 81aaf914ac1a6ae37f00185ad02ceb80894f994e SHA1 4bbd8700a0fec6db756917bc6d2b4a70b7df6cf1 SHA256 4351dc22a4d5ddd9cc3b4186f742f50e241af6191012ab80022d852e805bd9b4
MD5 685dc28c95b0628ff96761a51d507bca system-config-date-1.8.5.ebuild 1011
diff --git a/app-admin/system-config-date/files/1.8.5-gentooify.patch b/app-admin/system-config-date/files/1.8.5-gentooify.patch
index d835b4c..8dea3c0 100644
--- a/app-admin/system-config-date/files/1.8.5-gentooify.patch
+++ b/app-admin/system-config-date/files/1.8.5-gentooify.patch
@@ -1,11 +1,11 @@
-Index: dateBackend.py
+Index: src/dateBackend.py
===================================================================
RCS file: /usr/local/CVS/redhat-config-date/src/dateBackend.py,v
retrieving revision 1.38
diff -u -b -B -r1.38 dateBackend.py
--- src/dateBackend.py 6 Mar 2006 15:35:42 -0000 1.38
-+++ src/dateBackend.py 4 Sep 2006 05:53:46 -0000
-@@ -309,9 +309,9 @@
++++ src/dateBackend.py 4 Sep 2006 17:37:27 -0000
+@@ -309,28 +309,28 @@
def startNtpService (self, wait):
if self.isNtpRunning() == 1:
@@ -13,11 +13,13 @@ diff -u -b -B -r1.38 dateBackend.py
+ fullPath = '/etc/init.d/ntpd restart > /dev/null'
else:
- fullPath = '/sbin/service ntpd start > /dev/null'
+- path = "/sbin/service"
+- args = [path, "ntpd", "restart"]
+ fullPath = '/etc/init.d/ntpd start > /dev/null'
- path = "/sbin/service"
- args = [path, "ntpd", "restart"]
++ path = "/etc/init.d/ntpd"
++ args = [path, "restart"]
-@@ -319,16 +319,16 @@
+ retval = os.system(fullPath)
return retval
def chkconfigOn(self):
@@ -35,8 +37,11 @@ diff -u -b -B -r1.38 dateBackend.py
- path = ('/sbin/service ntpd stop > /dev/null')
+ path = ('/etc/init.d/ntpd stop > /dev/null')
os.system (path)
- path = ('/sbin/chkconfig --level 35 ntpd off')
+- path = ('/sbin/chkconfig --level 35 ntpd off')
++ path = ('/sbin/rc-update del ntpd')
os.system (path)
+
+ def isNtpRunning (self):
@@ -338,7 +338,7 @@
#The file doesn't exist, so return
return 0
@@ -46,3 +51,22 @@ diff -u -b -B -r1.38 dateBackend.py
result = os.system(command)
+Index: src/date_gui.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-date/src/date_gui.py,v
+retrieving revision 1.39
+diff -u -b -B -r1.39 date_gui.py
+--- src/date_gui.py 6 Mar 2006 15:35:42 -0000 1.39
++++ src/date_gui.py 4 Sep 2006 17:37:28 -0000
+@@ -137,9 +137,8 @@
+ self.ntpCheckButton.set_active(True)
+ elif ntpStatus == None:
+ text = (_("The NTP initscript (%s) does not seem to be functioning "
+- "properly. Try running 'rpm -V ntp' to see if the initscript "
+- "has been modified. system-config-date will exit now.")
+- % '/etc/rc.d/init.d/ntpd')
++ "properly. system-config-date will exit now.")
++ % '/etc/init.d/ntpd')
+ dlg = gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_OK, text)
+
+ dlg.set_title(_("Error"))
diff --git a/app-admin/system-config-nfs/Manifest b/app-admin/system-config-nfs/Manifest
index b8ecafc..11c341e 100644
--- a/app-admin/system-config-nfs/Manifest
+++ b/app-admin/system-config-nfs/Manifest
@@ -1,8 +1,12 @@
+AUX 1.3.19-gentooify.patch 1430 RMD160 5a78adf559ba36f628e5e8fe8d9f988b211c5aba SHA1 cc0d8df512a6606f891b34bed2bcad0b1373de2a SHA256 ed43812b0faf06e3df0897635e3772f535498ae5afa2de40b59a852d5be71e9d
+MD5 fff294097948d78b0e8bda4cb0740b91 files/1.3.19-gentooify.patch 1430
+RMD160 5a78adf559ba36f628e5e8fe8d9f988b211c5aba files/1.3.19-gentooify.patch 1430
+SHA256 ed43812b0faf06e3df0897635e3772f535498ae5afa2de40b59a852d5be71e9d files/1.3.19-gentooify.patch 1430
DIST system-config-nfs-1.3.19-1.1.src.rpm 133923 RMD160 1de98db3631a7ff89f82ecb8c09d401f4f418eeb SHA1 0f5975c4806a161bfd118c4cb6c2c19afbbde460 SHA256 380c9acff9c0b1410a606842ee8e2ccde78d4af1c9c0d58d4684d67b11dc82e2
-EBUILD system-config-nfs-1.3.19.ebuild 868 RMD160 70b593b1dc0560e4adce6824b2d6578fe857fd8b SHA1 36988d7a17a0db4a4e355f681b565f33940ef7eb SHA256 237a88cbc1570cbb692d9252e591219f59e28670ccbb00595e1e3ba4e3c0def7
-MD5 c2346e71f4c97e0c65f5c89fef4e00f2 system-config-nfs-1.3.19.ebuild 868
-RMD160 70b593b1dc0560e4adce6824b2d6578fe857fd8b system-config-nfs-1.3.19.ebuild 868
-SHA256 237a88cbc1570cbb692d9252e591219f59e28670ccbb00595e1e3ba4e3c0def7 system-config-nfs-1.3.19.ebuild 868
+EBUILD system-config-nfs-1.3.19.ebuild 964 RMD160 d124440a23ce2de149cd0e431f88e13aa66c42b1 SHA1 7a55f4e855944fbcb9011b4cea2066b6b93ef4b9 SHA256 5ef415f5f1dd45846bf4c42b82b6c90e34a1d279f883603c381e097bb0ef2979
+MD5 ae7e171be39edd0ed1ee68051d3b3f11 system-config-nfs-1.3.19.ebuild 964
+RMD160 d124440a23ce2de149cd0e431f88e13aa66c42b1 system-config-nfs-1.3.19.ebuild 964
+SHA256 5ef415f5f1dd45846bf4c42b82b6c90e34a1d279f883603c381e097bb0ef2979 system-config-nfs-1.3.19.ebuild 964
MD5 2d13cb3e6b25a09bc96a98fe7ca98c98 files/digest-system-config-nfs-1.3.19 289
RMD160 c050d594780814467aae4bb662220ba5241772ff files/digest-system-config-nfs-1.3.19 289
SHA256 907ca3f5869ba703de7ddfa2fc2741fac9d644b87ec09aaca4bae43f986b092c files/digest-system-config-nfs-1.3.19 289
diff --git a/app-admin/system-config-nfs/files/1.3.19-gentooify.patch b/app-admin/system-config-nfs/files/1.3.19-gentooify.patch
new file mode 100644
index 0000000..0b073e6
--- /dev/null
+++ b/app-admin/system-config-nfs/files/1.3.19-gentooify.patch
@@ -0,0 +1,36 @@
+Index: src/nfsExports.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-nfs/src/nfsExports.py,v
+retrieving revision 1.7
+diff -u -b -B -r1.7 nfsExports.py
+--- src/nfsExports.py 21 Mar 2005 16:35:46 -0000 1.7
++++ src/nfsExports.py 4 Sep 2006 17:31:17 -0000
+@@ -517,8 +517,8 @@
+ share.clients.append (client)
+
+ def startNfs (self):
+- os.system('/sbin/service portmap restart > /dev/null')
+- os.system('/sbin/service nfs start > /dev/null')
++ os.system('/etc/init.d/portmap restart > /dev/null')
++ os.system('/etc/init.d/nfs start > /dev/null')
+
+ def exportFs (self):
+ os.system('/usr/sbin/exportfs -r')
+Index: src/nfsServer.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-nfs/src/nfsServer.py,v
+retrieving revision 1.1
+diff -u -b -B -r1.1 nfsServer.py
+--- src/nfsServer.py 13 Oct 2005 09:11:33 -0000 1.1
++++ src/nfsServer.py 4 Sep 2006 17:31:17 -0000
+@@ -43,8 +43,8 @@
+ nfsServer.instantiated = False
+
+ def startNfs (self):
+- os.system('/sbin/service portmap restart > /dev/null')
+- os.system('/sbin/service nfs restart > /dev/null')
++ os.system('/etc/init.d/portmap restart > /dev/null')
++ os.system('/etc/init.d/nfs restart > /dev/null')
+
+ def exportFs (self):
+ os.system('/usr/sbin/exportfs -r')
diff --git a/app-admin/system-config-nfs/system-config-nfs-1.3.19.ebuild b/app-admin/system-config-nfs/system-config-nfs-1.3.19.ebuild
index bf825b2..eb77971 100644
--- a/app-admin/system-config-nfs/system-config-nfs-1.3.19.ebuild
+++ b/app-admin/system-config-nfs/system-config-nfs-1.3.19.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit rpm
+inherit eutils rpm
# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
# tarball out of it
@@ -27,6 +27,12 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/intltool"
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
diff --git a/app-admin/system-config-samba/Manifest b/app-admin/system-config-samba/Manifest
index 76bbbb8..629aed7 100644
--- a/app-admin/system-config-samba/Manifest
+++ b/app-admin/system-config-samba/Manifest
@@ -1,8 +1,12 @@
+AUX 1.2.35-gentooify.patch 1166 RMD160 4b58e13a44d775d77e01f96219b8f0b33e9ee883 SHA1 da4ae7d070b129c0fa4df243b95debc5fba84b2b SHA256 9f27eac1b7e2319a3c3fa7df38fb5a53ef2d26fd9520a78b93a3b313a0523e0b
+MD5 2934513d7cd06898ae75168431a00eaa files/1.2.35-gentooify.patch 1166
+RMD160 4b58e13a44d775d77e01f96219b8f0b33e9ee883 files/1.2.35-gentooify.patch 1166
+SHA256 9f27eac1b7e2319a3c3fa7df38fb5a53ef2d26fd9520a78b93a3b313a0523e0b files/1.2.35-gentooify.patch 1166
DIST system-config-samba-1.2.35-1.1.src.rpm 188958 RMD160 2f3c3fe3a2d1177194d731f35f2879aa825c4958 SHA1 cc936e966e9ee9d59a3e5485ec8633c8c1a33bf1 SHA256 b9e3e7f305917046d6e35761b60825087b997986200485cbd91ab7bb2f76bc8a
-EBUILD system-config-samba-1.2.35.ebuild 826 RMD160 8623885b1f3164432440d81b7f6ba3695ed81986 SHA1 188a67c77d638845a57c215f8fca2e249bed9876 SHA256 9cca82c3f2a0e25c5bc677f2bd3bf3344aa3c4fa77da5cd8a0dd8aa9684afcfb
-MD5 f16cc5d5d39852d7b2782479806f9c6b system-config-samba-1.2.35.ebuild 826
-RMD160 8623885b1f3164432440d81b7f6ba3695ed81986 system-config-samba-1.2.35.ebuild 826
-SHA256 9cca82c3f2a0e25c5bc677f2bd3bf3344aa3c4fa77da5cd8a0dd8aa9684afcfb system-config-samba-1.2.35.ebuild 826
+EBUILD system-config-samba-1.2.35.ebuild 922 RMD160 5d7710c2e80b0519f8c716ddf9fd150b4ec0a954 SHA1 fa2ce0c5054dcc14e430bb19c67ff58491e3ebca SHA256 9e7f74fde6559621ee28eded653342efb570a617eaea7bfc365605caec0ff173
+MD5 857e20ac4ce6ed338054df353a9a2368 system-config-samba-1.2.35.ebuild 922
+RMD160 5d7710c2e80b0519f8c716ddf9fd150b4ec0a954 system-config-samba-1.2.35.ebuild 922
+SHA256 9e7f74fde6559621ee28eded653342efb570a617eaea7bfc365605caec0ff173 system-config-samba-1.2.35.ebuild 922
MD5 e77cbdea75c0e0ed78febf7ad7f84050 files/digest-system-config-samba-1.2.35 295
RMD160 df89634e74250fff0f5cf0201cd5df681fc36b6f files/digest-system-config-samba-1.2.35 295
SHA256 652f5f979a3c267147140de9469f21c64cd7e258a27068c2ed23e2b6971ccfad files/digest-system-config-samba-1.2.35 295
diff --git a/app-admin/system-config-samba/files/1.2.35-gentooify.patch b/app-admin/system-config-samba/files/1.2.35-gentooify.patch
new file mode 100644
index 0000000..2efbae1
--- /dev/null
+++ b/app-admin/system-config-samba/files/1.2.35-gentooify.patch
@@ -0,0 +1,35 @@
+Index: src/sambaBackend.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-samba/src/sambaBackend.py,v
+retrieving revision 1.14
+diff -u -b -B -r1.14 sambaBackend.py
+--- src/sambaBackend.py 4 Mar 2004 23:55:01 -0000 1.14
++++ src/sambaBackend.py 4 Sep 2006 17:34:12 -0000
+@@ -31,7 +31,7 @@
+ class SambaBackend:
+
+ def isSmbRunning(self):
+- fd = os.popen('LC_MESSAGES=C /etc/init.d/smb status')
++ fd = os.popen('LC_MESSAGES=C /etc/init.d/samba status')
+ lines = fd.readlines()
+ fd.close()
+
+@@ -43,14 +43,14 @@
+ return 1
+
+ def startSamba(self):
+- path = '/sbin/service'
+- args = ['/sbin/service', 'smb', 'start']
++ path = '/etc/init.d/samba'
++ args = ['/etc/init.d/samba', 'start']
+
+- fd = os.popen('/sbin/service smb start')
++ fd = os.popen('/etc/init.d/samba start')
+ lines = fd.readlines()
+ fd.close()
+
+ def restartSamba(self):
+- fd = os.popen('/sbin/service smb restart')
++ fd = os.popen('/etc/init.d/samba restart')
+ lines = fd.readlines()
+ fd.close()
diff --git a/app-admin/system-config-samba/system-config-samba-1.2.35.ebuild b/app-admin/system-config-samba/system-config-samba-1.2.35.ebuild
index 6c7547f..eb25a5c 100644
--- a/app-admin/system-config-samba/system-config-samba-1.2.35.ebuild
+++ b/app-admin/system-config-samba/system-config-samba-1.2.35.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit rpm
+inherit eutils rpm
# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
# tarball out of it
@@ -25,6 +25,12 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/intltool"
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"