summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2010-09-10 19:55:19 +0000
committerAntoine Pitrou <solipsis@pitrou.net>2010-09-10 19:55:19 +0000
commit80f45a09985d8396209045db236eabb0f8f3bce4 (patch)
treecda1005d65a9038253e98a920c043451471c012c /Makefile.pre.in
parentMerged revisions 84677 via svnmerge from (diff)
downloadcpython-80f45a09985d8396209045db236eabb0f8f3bce4.tar.gz
cpython-80f45a09985d8396209045db236eabb0f8f3bce4.tar.bz2
cpython-80f45a09985d8396209045db236eabb0f8f3bce4.zip
Merged revisions 84680 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r84680 | antoine.pitrou | 2010-09-10 21:44:44 +0200 (ven., 10 sept. 2010) | 4 lines Issue #941346: Improve the build process under AIX and allow Python to be built as a shared library. Patch by Sébastien Sablé. ........
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index c18bd0ae818..6c2f4d1c3cb 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -435,10 +435,10 @@ $(LIBRARY): $(LIBRARY_OBJS)
libpython$(VERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
- $(LDSHARED) $(LDFLAGS) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
+ $(BLDSHARED) $(LDFLAGS) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
$(LN) -f $(INSTSONAME) $@; \
else \
- $(LDSHARED) $(LDFLAGS) -o $@ $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
+ $(BLDSHARED) $(LDFLAGS) -o $@ $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
fi
libpython$(VERSION).dylib: $(LIBRARY_OBJS)
@@ -1189,7 +1189,7 @@ clobber: clean profile-removal
distclean: clobber
-rm -f core Makefile Makefile.pre config.status \
Modules/Setup Modules/Setup.local Modules/Setup.config \
- Misc/python.pc
+ Modules/ld_so_aix Misc/python.pc
find $(srcdir) '(' -name '*.fdc' -o -name '*~' \
-o -name '[@,#]*' -o -name '*.old' \
-o -name '*.orig' -o -name '*.rej' \