aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2017-12-25 12:35:28 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-11 10:16:57 +0100
commitea4edf596619a6d26d08194e4c4965bc05871798 (patch)
tree897c60caa16e7457a6e19c5349efad1937308ef4
parentmeson: when pivot_root() is added one day, look for it in <unistd.h> (diff)
downloadsystemd-ea4edf596619a6d26d08194e4c4965bc05871798.tar.gz
systemd-ea4edf596619a6d26d08194e4c4965bc05871798.tar.bz2
systemd-ea4edf596619a6d26d08194e4c4965bc05871798.zip
meson: look for gettid() definition where getpid() is defined
Hopefully, should gettid() show up one day in glibc it'll show up where getpid() is defined too. (cherry picked from commit 7b961e40ee5cd5c453cad70906327ea5a11fa75e)
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7d680150b..dcc4f1ef0 100644
--- a/meson.build
+++ b/meson.build
@@ -454,7 +454,8 @@ endforeach
foreach ident : [
['memfd_create', '''#include <sys/mman.h>'''],
- ['gettid', '''#include <sys/types.h>'''],
+ ['gettid', '''#include <sys/types.h>
+ #include <unistd.h>'''],
['pivot_root', '''#include <stdlib.h>
#include <unistd.h>'''], # no known header declares pivot_root
['name_to_handle_at', '''#include <sys/types.h>