aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-02-15 09:07:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-02-15 09:07:07 +0000
commitff304ece7c6c09347935e131efdc55048fb5630b (patch)
treed0915ca0920d5a01ae013787f9a2296c55947eb7
parentUpdate version closing bug #32830. Change to automake's style of selecting (diff)
downloadautotools-wrappers-ff304ece7c6c09347935e131efdc55048fb5630b.tar.gz
autotools-wrappers-ff304ece7c6c09347935e131efdc55048fb5630b.tar.bz2
autotools-wrappers-ff304ece7c6c09347935e131efdc55048fb5630b.zip
Fix ac-wrapper.pl to also work with AC_PREREQ(2.50) (note the 2.50 and not 2.5).
-rwxr-xr-xac-wrapper.pl4
1 files changed, 2 insertions, 2 deletions
diff --git a/ac-wrapper.pl b/ac-wrapper.pl
index 561cea3..c720d9f 100755
--- a/ac-wrapper.pl
+++ b/ac-wrapper.pl
@@ -54,10 +54,10 @@ if ($ENV{WANT_AUTOCONF} ne '2.1') {
|| (-x $binary_new # user may have only 2.13
&& (($ENV{WANT_AUTOCONF} eq '2.5')
|| -r 'configure.ac'
- || (cat_('configure.in') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure.in') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
|| (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || (cat_('aclocal.m4') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'))) {
+ || (cat_('aclocal.m4') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/m ? $1 : '') gt '2.1'))) {
$ENV{WANT_AUTOCONF} = '2.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
} else {