aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Bier <Felix.Bier@rohde-schwarz.com>2021-02-04 00:34:14 +0000
committerMatt Turner <mattst88@gentoo.org>2021-02-19 21:27:06 -0500
commitd5f85bc8d71d89920332ce760e5da3dca257dc36 (patch)
treef35de56724f56015c2d65c85cca1fc7da98d1d80 /catalyst
parentcatalyst: Clean up exception handling (diff)
downloadcatalyst-d5f85bc8d71d89920332ce760e5da3dca257dc36.tar.gz
catalyst-d5f85bc8d71d89920332ce760e5da3dca257dc36.tar.bz2
catalyst-d5f85bc8d71d89920332ce760e5da3dca257dc36.zip
Rename config option 'repos' -> 'repos_storedir'
This commit renames the config option 'repos' to 'repos_storedir'. This is done as preparation for renaming 'portage_overlay' to 'repos'. Signed-off-by: Felix Bier <felix.bier@rohde-schwarz.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'catalyst')
-rw-r--r--catalyst/defaults.py4
-rw-r--r--catalyst/targets/snapshot.py2
2 files changed, 3 insertions, 3 deletions
diff --git a/catalyst/defaults.py b/catalyst/defaults.py
index 3f12b8d5..3d5c0a7f 100644
--- a/catalyst/defaults.py
+++ b/catalyst/defaults.py
@@ -20,7 +20,7 @@ valid_config_file_values = frozenset([
"port_logdir",
"repo_basedir",
"repo_name",
- "repos",
+ "repos_storedir",
"sharedir",
"storedir",
"target_distdir",
@@ -46,7 +46,7 @@ confdefaults = {
"port_tmpdir": "/var/tmp/portage",
"repo_basedir": "/var/db/repos",
"repo_name": "gentoo",
- "repos": "%(storedir)s/repos",
+ "repos_storedir": "%(storedir)s/repos",
"sharedir": "/usr/share/catalyst",
"shdir": "%(sharedir)s/targets",
"storedir": "/var/tmp/catalyst",
diff --git a/catalyst/targets/snapshot.py b/catalyst/targets/snapshot.py
index 6b727600..b494575a 100644
--- a/catalyst/targets/snapshot.py
+++ b/catalyst/targets/snapshot.py
@@ -27,7 +27,7 @@ class snapshot(TargetBase):
TargetBase.__init__(self, myspec, addlargs)
self.git = command('git')
- self.ebuild_repo = Path(self.settings['repos'],
+ self.ebuild_repo = Path(self.settings['repos_storedir'],
self.settings['repo_name']).with_suffix('.git')
self.gitdir = str(self.ebuild_repo)