summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'demos/c/Makefile')
-rw-r--r--demos/c/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/demos/c/Makefile b/demos/c/Makefile
new file mode 100644
index 00000000..63dc4da5
--- /dev/null
+++ b/demos/c/Makefile
@@ -0,0 +1,12 @@
+api_test: api_test.c
+ (cd ../.. && ./autogen.sh)
+ (cd ../.. && make so XCFLAGS="-DCLUSTER")
+ pwd
+ gcc -fPIC -I../.. api_test.c -DGHOSTPDL=1 -lgpdl -L../../sobin -o api_test
+
+run_api_test: api_test
+ LD_LIBRARY_PATH=../../sobin ./api_test
+
+post_api_test:
+ md5sum apitest*
+ rm apitest*