summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-05-16 20:18:44 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-05-16 20:18:44 +0000
commitbbe9d374b9e0b4eae5583f54cc99a89c10606a20 (patch)
treedb1ca809dd97ed7eef4f2f53a4283bd741572f17
downloadeselect-bbe9d374b9e0b4eae5583f54cc99a89c10606a20.tar.gz
eselect-bbe9d374b9e0b4eae5583f54cc99a89c10606a20.tar.bz2
eselect-bbe9d374b9e0b4eae5583f54cc99a89c10606a20.zip
svn path=/website/; revision=110
-rw-r--r--Makefile14
-rw-r--r--default.css58
-rw-r--r--developer-guide.shtml15
-rw-r--r--index.shtml28
-rw-r--r--overview.shtml15
-rw-r--r--release-guide.shtml15
-rw-r--r--user-guide.shtml15
7 files changed, 160 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..e60f2bf
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+all : docs
+
+docs : doc-overview doc-developer-guide doc-user-guide doc-release-guide
+
+upload :
+ scp *.content *.css *.shtml \
+ shell.berlios.de:/home/groups/eclectic/htdocs/
+
+doc-% : ../trunk/doc/%.txt
+ cp $? ./$*.txt
+ rst2html.py < $*.txt | sed -n -e '/<body>/,/<\/body>/p' > $*.content
+
+
+
diff --git a/default.css b/default.css
new file mode 100644
index 0000000..bb30492
--- /dev/null
+++ b/default.css
@@ -0,0 +1,58 @@
+body {
+ background-color: #ffffee;
+ color: #333366;
+ font-family: "Verdana", sans-serif;
+}
+
+h1 {
+ text-align: center;
+}
+
+h2 {
+ text-align: left;
+}
+
+a[href]:link, a[href]:visited {
+ color: #6666ff;
+ text-decoration: none
+}
+
+a[href]:hover {
+ color: #6666ff;
+ text-decoration: underline;
+}
+
+a[href]:active {
+ color: #333366;
+}
+
+code, tt {
+ font-family: "Terminus", monospace;
+ color: #cc0000;
+}
+
+pre {
+ background-color: #1e1e27;
+ color: #cfbfad;
+ padding-top: 3px;
+ padding-bottom: 3px;
+ padding-left: 8px;
+ padding-right: 8px;
+}
+
+div.warning p.admonition-title, div.note p.admonition-title {
+ font-weight: bold;
+ display: inline;
+}
+
+div.warning p, div.note p {
+ display: inline;
+}
+
+div.warning p.admonition-title:after, div.note p.admonition-title:after {
+ content: ":";
+}
+
+dt {
+ font-weight: bold;
+}
diff --git a/developer-guide.shtml b/developer-guide.shtml
new file mode 100644
index 0000000..222e24b
--- /dev/null
+++ b/developer-guide.shtml
@@ -0,0 +1,15 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<!-- vim: set ft=xhtml fenc=utf-8 foldmethod=marker : -->
+
+<html lang="en-GB" xml:lang="en-GB" xmlns="http://www.w3.org/1999/xhtml">
+<head>
+ <title>Eclectic Tool Framework: Developer Guide</title>
+ <link rel="stylesheet" href="default.css" type="text/css" />
+</head>
+
+<body>
+ <!--#include virtual="developer-guide.content" -->
+</body>
+</html>
+
diff --git a/index.shtml b/index.shtml
new file mode 100644
index 0000000..4247056
--- /dev/null
+++ b/index.shtml
@@ -0,0 +1,28 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<!-- vim: set ft=xhtml fenc=utf-8 foldmethod=marker : -->
+
+<html lang="en-GB" xml:lang="en-GB" xmlns="http://www.w3.org/1999/xhtml">
+<head>
+ <title>Eclectic Tool Framework</title>
+ <link rel="stylesheet" href="default.css" type="text/css" />
+</head>
+
+<body>
+ <h1>Eclectic Tool Framework</h1>
+ <p>Eclectic is a free, open source (GNU General Public Licence)
+ framework for writing configuration tools.</p>
+
+ <ul>
+ <li>Read a brief <a href="overview.shtml">overview of Eclectic</a>.</li>
+ <li><a href="https://developer.berlios.de/project/showfiles.php?group_id=3165">Download the
+ latest version of Eclectic</a>.</li>
+ <li>Find out about <a href="https://developer.berlios.de/svn/?group_id=3165">accessing the
+ project's Subversion repository</a>.</li>
+ <li>Read the <a href="user-guide.shtml">user guide</a>.</li>
+ <li>Read the <a href="developer-guide.shtml">developer guide</a>.</li>
+ <li>Read the <a href="release-guide.shtml">release guide</a>.</li>
+ </ul>
+</body>
+</html>
+
diff --git a/overview.shtml b/overview.shtml
new file mode 100644
index 0000000..fb2d21f
--- /dev/null
+++ b/overview.shtml
@@ -0,0 +1,15 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<!-- vim: set ft=xhtml fenc=utf-8 foldmethod=marker : -->
+
+<html lang="en-GB" xml:lang="en-GB" xmlns="http://www.w3.org/1999/xhtml">
+<head>
+ <title>Eclectic Tool Framework: Overview</title>
+ <link rel="stylesheet" href="default.css" type="text/css" />
+</head>
+
+<body>
+ <!--#include virtual="overview.content" -->
+</body>
+</html>
+
diff --git a/release-guide.shtml b/release-guide.shtml
new file mode 100644
index 0000000..f4c2044
--- /dev/null
+++ b/release-guide.shtml
@@ -0,0 +1,15 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<!-- vim: set ft=xhtml fenc=utf-8 foldmethod=marker : -->
+
+<html lang="en-GB" xml:lang="en-GB" xmlns="http://www.w3.org/1999/xhtml">
+<head>
+ <title>Eclectic Tool Framework: Release Guide</title>
+ <link rel="stylesheet" href="default.css" type="text/css" />
+</head>
+
+<body>
+ <!--#include virtual="release-guide.content" -->
+</body>
+</html>
+
diff --git a/user-guide.shtml b/user-guide.shtml
new file mode 100644
index 0000000..1de68fa
--- /dev/null
+++ b/user-guide.shtml
@@ -0,0 +1,15 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<!-- vim: set ft=xhtml fenc=utf-8 foldmethod=marker : -->
+
+<html lang="en-GB" xml:lang="en-GB" xmlns="http://www.w3.org/1999/xhtml">
+<head>
+ <title>Eclectic Tool Framework: User Guide</title>
+ <link rel="stylesheet" href="default.css" type="text/css" />
+</head>
+
+<body>
+ <!--#include virtual="user-guide.content" -->
+</body>
+</html>
+