summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-13 09:16:02 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-13 09:16:02 +0000
commit7dbff6dbe06e96bec891f9faa596f51ab0384936 (patch)
tree66cf2f7b19777b7907a116075b608e875ce831e3 /gnustep-libs
parentThrow away the old copy (diff)
downloadprefix-7dbff6dbe06e96bec891f9faa596f51ab0384936.tar.gz
prefix-7dbff6dbe06e96bec891f9faa596f51ab0384936.tar.bz2
prefix-7dbff6dbe06e96bec891f9faa596f51ab0384936.zip
add gnustep-libs/camaelon
(Portage 2.2.00.7595-prefix/SVN/Linux 2.6.20-1.2925.fc6 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+) svn path=/prefix-overlay/; revision=242
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/camaelon/Manifest3
-rw-r--r--gnustep-libs/camaelon/camaelon-0.2.ebuild25
-rw-r--r--gnustep-libs/camaelon/files/config-camaelon.sh5
3 files changed, 33 insertions, 0 deletions
diff --git a/gnustep-libs/camaelon/Manifest b/gnustep-libs/camaelon/Manifest
new file mode 100644
index 0000000..c80267a
--- /dev/null
+++ b/gnustep-libs/camaelon/Manifest
@@ -0,0 +1,3 @@
+AUX config-camaelon.sh 356 RMD160 c75a5e35cc0393b9988c2928c57acd15d0864f6c SHA1 725014a66ad2336f76fea89b2a6e37b102dcfee2 SHA256 f5fa31d210c040f2a04101a59817befb5983f6163d10b3b7bdb0fb436e55f6e2
+DIST etoile-0.2.tar.gz 21233211 RMD160 340add5114d6bd2ba9d6da648ec041702a09d565 SHA1 9d384114f5ac317eebcc6b5cda3a0f5898a7c1c7 SHA256 e3a016ceaeb28c02b9a7ac71db51ced38c0dc0fc36c8b539d878b826f988ae0f
+EBUILD camaelon-0.2.ebuild 705 RMD160 a80beb7447ddf0760ca5349202c22d56b41c9e26 SHA1 48069721bf29a25792101df9bca93ab79e528c12 SHA256 15f9d0e9e7dfd2c487664cb97f8a2958bba8e7f394aa944e51bfb351b42fb396
diff --git a/gnustep-libs/camaelon/camaelon-0.2.ebuild b/gnustep-libs/camaelon/camaelon-0.2.ebuild
new file mode 100644
index 0000000..c075d7f
--- /dev/null
+++ b/gnustep-libs/camaelon/camaelon-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Bundles/${PN/c/C}"
+
+DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
+
+HOMEPAGE="http://www.etoile-project.org/etoile/mediawiki/index.php?title=Camaelon"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+src_install() {
+ gnustep-base_src_install
+
+ #Link default theme
+ mkdir -p ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes
+ ln -s ${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine/Resources/Nesedah.theme ${D}${GNUSTEP_SYSTEM_LIBRARY}/Themes/
+}
diff --git a/gnustep-libs/camaelon/files/config-camaelon.sh b/gnustep-libs/camaelon/files/config-camaelon.sh
new file mode 100644
index 0000000..ee3c519
--- /dev/null
+++ b/gnustep-libs/camaelon/files/config-camaelon.sh
@@ -0,0 +1,5 @@
+echo "Applying Camaelon default theme..."
+echo "defaults write NSGlobalDomain GSAppKitUserBundles \"(/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine)\""
+defaults write NSGlobalDomain GSAppKitUserBundles "(/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine)"
+echo "defaults write Camaelon Theme Nesedah"
+defaults write Camaelon Theme Nesedah