aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-03 14:18:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-03 14:18:06 +0100
commitc4bab5dfd33273ba987009fba152d0713ff01c8d (patch)
treed0452ec8a6b7103373d4225be2d70522392ac92a /kde-frameworks/frameworkintegration
parentkde-misc/latte-dock: Raise >=KF-5.63 minimum to drop DEPEND (diff)
downloadkde-c4bab5dfd33273ba987009fba152d0713ff01c8d.tar.gz
kde-c4bab5dfd33273ba987009fba152d0713ff01c8d.tar.bz2
kde-c4bab5dfd33273ba987009fba152d0713ff01c8d.zip
kde-frameworks: Add KDE Frameworks 5.64.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.64.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
new file mode 100644
index 0000000000..a802c998c0
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -0,0 +1 @@
+DIST frameworkintegration-5.64.0.tar.xz 1754716 BLAKE2B a9812b62c8973b5286b06388a5a9bb2f65bed49684b72c56696ab8e5ea7a03b24ba9d8b58b210cfbd06d46a695106d81f22b5fbd6440bc68dc639c5385dbce62 SHA512 7288578fcec9c1fe1d768692380acff00267513e0092361b0c0739e669a86ffde1df96f20e0ce91685df440ae7fcd7786d96fc18c1faa00e5e82d7fc9b8d60df
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.64.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.64.0.ebuild
new file mode 100644
index 0000000000..f6721b5381
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.64.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets '' '' '5=')
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}