aboutsummaryrefslogtreecommitdiff
path: root/cfg.mk
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2012-05-17 17:08:53 +0200
committerMichal Privoznik <mprivozn@redhat.com>2012-06-02 10:40:51 +0200
commit0766783abbe8bbc9ea686c2c3149f4c0ac139e19 (patch)
tree4d1968f26669445b7397870c899015740bd88265 /cfg.mk
parentnwfilter: Add multiple IP address support to DHCP snooping (diff)
downloadlibvirt-0766783abbe8bbc9ea686c2c3149f4c0ac139e19.tar.gz
libvirt-0766783abbe8bbc9ea686c2c3149f4c0ac139e19.tar.bz2
libvirt-0766783abbe8bbc9ea686c2c3149f4c0ac139e19.zip
virsh: Switch from generated cmd*Edit commands to nongenerated
Currently, we either generate some cmd*Edit commands (cmdPoolEdit and cmdNetworkEdit) via sed script or copy the body of cmdEdit (e.g. cmdInterfaceEdit, cmdNWFilterEdit, etc.). This fact makes it harder to implement any new feature to our editing system. Therefore switch to new implementation - define macros to: - dump XML (EDIT_GET_XML) - take an action if XML wasn't changed, usually just vshPrint() (EDIT_NOT_CHANGED) - define new object (EDIT_DEFINE) - the edited XML is in @doc_edited - free object defined by EDIT_DEFINE (EDIT_FREE) and #include "virsh-edit.c"
Diffstat (limited to 'cfg.mk')
-rw-r--r--cfg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/cfg.mk b/cfg.mk
index 37f51a685..5d3813781 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -819,9 +819,9 @@ exclude_file_name_regexp--sc_prohibit_xmlURI = ^src/util/viruri\.c$$
exclude_file_name_regexp--sc_prohibit_return_as_function = \.py$$
-exclude_file_name_regexp--sc_require_config_h = ^examples/
+exclude_file_name_regexp--sc_require_config_h = ^(examples/|tools/virsh-edit.c$$)
-exclude_file_name_regexp--sc_require_config_h_first = ^examples/
+exclude_file_name_regexp--sc_require_config_h_first = ^(examples/|tools/virsh-edit.c$$)
exclude_file_name_regexp--sc_trailing_blank = \
(/qemuhelpdata/|\.(fig|gif|ico|png)$$)