aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2007-07-25 23:16:30 +0000
committerDaniel P. Berrange <berrange@redhat.com>2007-07-25 23:16:30 +0000
commit773aa3b86b969169bfca8e20d527ae4704901be4 (patch)
tree72e4417a00c58ac009194a11ba939a1e66203831 /src/nodeinfo.h
parentOops forgot to rev in configure.in, Daniel (diff)
downloadlibvirt-773aa3b86b969169bfca8e20d527ae4704901be4.tar.gz
libvirt-773aa3b86b969169bfca8e20d527ae4704901be4.tar.bz2
libvirt-773aa3b86b969169bfca8e20d527ae4704901be4.zip
Split out generic nodeinfo API
Diffstat (limited to 'src/nodeinfo.h')
-rw-r--r--src/nodeinfo.h39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/nodeinfo.h b/src/nodeinfo.h
new file mode 100644
index 000000000..d0d0bb29c
--- /dev/null
+++ b/src/nodeinfo.h
@@ -0,0 +1,39 @@
+/*
+ * nodeinfo.c: Helper routines for OS specific node information
+ *
+ * Copyright (C) 2006, 2007 Red Hat, Inc.
+ * Copyright (C) 2006 Daniel P. Berrange
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ *
+ * Author: Daniel P. Berrange <berrange@redhat.com>
+ */
+
+#ifndef __VIR_NODEINFO_H__
+#define __VIR_NODEINFO_H__
+
+#include "internal.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+ int virNodeInfoPopulate(virConnectPtr conn, virNodeInfoPtr nodeinfo);
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif /* __VIR_NODEINFO_H__*/