diff options
-rw-r--r-- | .gitignore | 3 | ||||
-rw-r--r-- | Makefile | 10 | ||||
-rw-r--r-- | overlint/cli.py | 2 | ||||
-rwxr-xr-x | setup.py | 18 |
4 files changed, 31 insertions, 2 deletions
@@ -1,2 +1,3 @@ *.pyc - +/dist +/MANIFEST diff --git a/Makefile b/Makefile new file mode 100644 index 0000000..f28f886 --- /dev/null +++ b/Makefile @@ -0,0 +1,10 @@ +# Copyright (C) 2012 Sebastian Pipping <sebastian@pipping.org> +# Licensed under GPL v2 or later + +all: + +dist: + rm -f MANIFEST + ./setup.py sdist + +.PHONY: dist diff --git a/overlint/cli.py b/overlint/cli.py index d941f25..4ba402c 100644 --- a/overlint/cli.py +++ b/overlint/cli.py @@ -3,7 +3,7 @@ from __future__ import print_function -VERSION_STR = '0.4' +VERSION_STR = '0.4.1' import sys import os diff --git a/setup.py b/setup.py new file mode 100755 index 0000000..08244ba --- /dev/null +++ b/setup.py @@ -0,0 +1,18 @@ +#!/usr/bin/env python +# Copyright (C) 2012 Sebastian Pipping <sebastian@pipping.org> +# Licensed under GPL v2 or later + +from distutils.core import setup +from overlint.cli import VERSION_STR + +setup( + name='overlint', + description='Simple tool for static analysis of Gentoo overlays', + license='GPL v2 or later', + version=VERSION_STR, + url='http://git.overlays.gentoo.org/gitweb/?p=proj/overlint.git;a=summary', + author='Sebastian Pipping', + author_email='sebastian@pipping.org', + packages=['overlint', ], + scripts=['overlint-cli', ], +) |