aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--README.rst8
2 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 84ed70add..1efb6afd1 100644
--- a/Makefile
+++ b/Makefile
@@ -17,3 +17,7 @@ clean:
.PHONY: format
format:
$(PYTHON) -m black .
+
+.PHONY: dev-environment
+dev-environment:
+ $(PYTHON) -m pip install -e .[test,doc,formatter]
diff --git a/README.rst b/README.rst
index 7b18f6802..e02156aa0 100644
--- a/README.rst
+++ b/README.rst
@@ -52,6 +52,14 @@ Installing from a tarball::
pip install .
+Developing
+==========
+
+Installing the dependencies for testing, formatting, and documentation building
+into an editable environment::
+
+ make dev-environment
+
Tests
=====