summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-10-12 10:26:12 -0400
committerMike Gilbert <floppym@gentoo.org>2014-10-12 10:26:12 -0400
commit383c2c4c991ab4f653cca6ba6cefe752b2acb169 (patch)
tree0637ecdb50232405c5570ade74c91892b3683208
parentUpdates for 3.4.1, thanks to Arfrever. (diff)
downloadpython-gentoo-patches-383c2c4c991ab4f653cca6ba6cefe752b2acb169.tar.gz
python-gentoo-patches-383c2c4c991ab4f653cca6ba6cefe752b2acb169.tar.bz2
python-gentoo-patches-383c2c4c991ab4f653cca6ba6cefe752b2acb169.zip
Updates for 3.4.2 by Arfrever.3.4.2-03.4.2
-rw-r--r--patches/01_all_static_library_location.patch6
-rw-r--r--patches/02_all_disable_modules_and_ssl.patch10
-rw-r--r--patches/03_all_libdir.patch59
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch12
-rw-r--r--patches/05_all_regenerate_platform-specific_modules.patch12
-rw-r--r--patches/21_all_distutils_c++.patch10
-rw-r--r--patches/22_all_tests_environment.patch4
-rw-r--r--patches/23_all_h2py_encoding.patch2
8 files changed, 84 insertions, 31 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index eda2c9d..8f92994 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -1,10 +1,10 @@
Install libpythonX.Y.a in /usr/lib instead of /usr/lib/pythonX.Y/config.
https://bugs.gentoo.org/show_bug.cgi?id=252372
-http://bugs.python.org/issue6103
+https://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -989,6 +989,19 @@
+@@ -1004,6 +1004,19 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) -m ensurepip \
$$ensurepip --root=$(DESTDIR)/ ; \
fi
@@ -24,7 +24,7 @@ http://bugs.python.org/issue6103
commoninstall: @FRAMEWORKALTINSTALLFIRST@ \
altbininstall libinstall inclinstall libainstall \
-@@ -1309,18 +1322,6 @@
+@@ -1324,18 +1337,6 @@
else true; \
fi; \
done
diff --git a/patches/02_all_disable_modules_and_ssl.patch b/patches/02_all_disable_modules_and_ssl.patch
index a8bd8e4..f5f050b 100644
--- a/patches/02_all_disable_modules_and_ssl.patch
+++ b/patches/02_all_disable_modules_and_ssl.patch
@@ -1,6 +1,6 @@
--- setup.py
+++ setup.py
-@@ -33,7 +33,17 @@
+@@ -39,7 +39,17 @@
COMPILED_WITH_PYDEBUG = ('--with-pydebug' in sysconfig.get_config_var("CONFIG_ARGS"))
# This global variable is used to hold the list of modules to be disabled.
@@ -19,7 +19,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (after any relative
-@@ -441,6 +451,7 @@
+@@ -447,6 +457,7 @@
os.unlink(tmpfile)
def detect_modules(self):
@@ -27,7 +27,7 @@
# Ensure that /usr/local is always used, but the local build
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
-@@ -757,7 +768,7 @@
+@@ -765,7 +776,7 @@
ssl_incs = find_file('openssl/ssl.h', inc_dirs,
search_for_ssl_incs_in
)
@@ -36,7 +36,7 @@
krb5_h = find_file('krb5.h', inc_dirs,
['/usr/kerberos/include'])
if krb5_h:
-@@ -768,7 +779,8 @@
+@@ -776,7 +787,8 @@
] )
if (ssl_incs is not None and
@@ -46,7 +46,7 @@
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,
-@@ -801,7 +813,7 @@
+@@ -809,7 +821,7 @@
#print('openssl_ver = 0x%08x' % openssl_ver)
min_openssl_ver = 0x00907000
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index b0b68ee..e85d646 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -1,6 +1,6 @@
--- Lib/distutils/command/install.py
+++ Lib/distutils/command/install.py
-@@ -44,8 +44,8 @@
+@@ -29,8 +29,8 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@@ -86,7 +86,7 @@
# other platforms
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -115,7 +115,7 @@
+@@ -120,7 +120,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -148,7 +148,16 @@
#
--- setup.py
+++ setup.py
-@@ -513,8 +513,7 @@
+@@ -462,7 +462,7 @@
+ # directories (i.e. '.' and 'Include') must be first. See issue
+ # 10520.
+ if not cross_compiling:
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ add_dir_to_list(self.compiler.library_dirs, '/usr/local/@@GENTOO_LIBDIR@@')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ # only change this for cross builds for 3.3, issues on Mageia
+ if cross_compiling:
+@@ -519,8 +519,7 @@
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
lib_dirs = self.compiler.library_dirs + [
@@ -158,7 +167,7 @@
]
inc_dirs = self.compiler.include_dirs + ['/usr/include']
else:
-@@ -733,11 +732,11 @@
+@@ -741,11 +740,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -172,3 +181,45 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
+@@ -1002,8 +1001,7 @@
+
+ # check lib directories parallel to the location of the header
+ db_dirs_to_check = [
+- db_incdir.replace("include", 'lib64'),
+- db_incdir.replace("include", 'lib'),
++ db_incdir.replace("include", '@@GENTOO_LIBDIR@@'),
+ ]
+
+ if host_platform != 'darwin':
+@@ -1114,10 +1112,8 @@
+
+ if sqlite_incdir:
+ sqlite_dirs_to_check = [
+- os.path.join(sqlite_incdir, '..', 'lib64'),
+- os.path.join(sqlite_incdir, '..', 'lib'),
+- os.path.join(sqlite_incdir, '..', '..', 'lib64'),
+- os.path.join(sqlite_incdir, '..', '..', 'lib'),
++ os.path.join(sqlite_incdir, '..', '@@GENTOO_LIBDIR@@'),
++ os.path.join(sqlite_incdir, '..', '..', '@@GENTOO_LIBDIR@@'),
+ ]
+ sqlite_libfile = self.compiler.find_library_file(
+ sqlite_dirs_to_check + lib_dirs, 'sqlite3')
+@@ -1765,15 +1761,14 @@
+ added_lib_dirs.append('/usr/openwin/lib')
+ elif os.path.exists('/usr/X11R6/include'):
+ include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
++ added_lib_dirs.append('/usr/X11R6/@@GENTOO_LIBDIR@@')
+ elif os.path.exists('/usr/X11R5/include'):
+ include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
++ added_lib_dirs.append('/usr/X11R5/@@GENTOO_LIBDIR@@')
+ else:
+ # Assume default location for X11
+ include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
++ added_lib_dirs.append('/usr/X11/@@GENTOO_LIBDIR@@')
+
+ # If Cygwin, then verify that X is installed before proceeding
+ if host_platform == 'cygwin':
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index 995cba1..b51eb4f 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -1,9 +1,9 @@
https://bugs.gentoo.org/show_bug.cgi?id=281968
-http://bugs.python.org/issue6731
+https://bugs.python.org/issue6731
--- setup.py
+++ setup.py
-@@ -45,6 +45,8 @@
+@@ -51,6 +51,8 @@
else:
disable_ssl = 0
@@ -12,16 +12,18 @@ http://bugs.python.org/issue6731
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (after any relative
directories) if:
-@@ -280,6 +282,8 @@
+@@ -285,7 +287,10 @@
+ " detect_modules() for the module's name.")
print()
++ global exit_status
++
if self.failed:
-+ global exit_status
+ exit_status = 1
failed = self.failed[:]
print()
print("Failed to build these modules:")
-@@ -2229,6 +2233,7 @@
+@@ -2233,6 +2238,7 @@
scripts = ["Tools/scripts/pydoc3", "Tools/scripts/idle3",
"Tools/scripts/2to3", "Tools/scripts/pyvenv"]
)
diff --git a/patches/05_all_regenerate_platform-specific_modules.patch b/patches/05_all_regenerate_platform-specific_modules.patch
index ab59fc5..bfb5a82 100644
--- a/patches/05_all_regenerate_platform-specific_modules.patch
+++ b/patches/05_all_regenerate_platform-specific_modules.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue12619
+https://bugs.python.org/issue12619
--- Lib/plat-aix4/regen
+++ Lib/plat-aix4/regen
@@ -37,7 +37,7 @@ http://bugs.python.org/issue12619
+python$EXE ../../Tools/scripts/h2py.py /usr/include/sys/stropts.h
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -459,7 +459,7 @@
+@@ -464,7 +464,7 @@
# Default target
all: build_all
@@ -46,7 +46,7 @@ http://bugs.python.org/issue12619
# Compile a binary with gcc profile guided optimization.
profile-opt:
-@@ -557,6 +557,32 @@
+@@ -572,6 +572,32 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -79,7 +79,7 @@ http://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -1174,7 +1200,7 @@
+@@ -1189,7 +1215,7 @@
unittest unittest/test unittest/test/testmock \
venv venv/scripts venv/scripts/posix \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ http://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1257,23 +1283,6 @@
+@@ -1272,23 +1298,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ http://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1596,7 +1605,7 @@
+@@ -1611,7 +1620,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/21_all_distutils_c++.patch b/patches/21_all_distutils_c++.patch
index d436573..6e8ef61 100644
--- a/patches/21_all_distutils_c++.patch
+++ b/patches/21_all_distutils_c++.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue1222585
+https://bugs.python.org/issue1222585
--- Lib/distutils/cygwinccompiler.py
+++ Lib/distutils/cygwinccompiler.py
@@ -60,7 +60,7 @@ http://bugs.python.org/issue1222585
# dlls need another dll (mingwm10.dll see Mingw32 docs)
--- Lib/distutils/sysconfig.py
+++ Lib/distutils/sysconfig.py
-@@ -184,9 +184,12 @@
+@@ -182,9 +182,12 @@
_osx_support.customize_compiler(_config_vars)
_config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
@@ -76,7 +76,7 @@ http://bugs.python.org/issue1222585
if 'CC' in os.environ:
newcc = os.environ['CC']
-@@ -201,19 +204,27 @@
+@@ -199,19 +202,27 @@
cxx = os.environ['CXX']
if 'LDSHARED' in os.environ:
ldshared = os.environ['LDSHARED']
@@ -105,7 +105,7 @@ http://bugs.python.org/issue1222585
if 'AR' in os.environ:
ar = os.environ['AR']
if 'ARFLAGS' in os.environ:
-@@ -222,13 +233,17 @@
+@@ -220,13 +231,17 @@
archiver = ar + ' ' + ar_flags
cc_cmd = cc + ' ' + cflags
@@ -229,7 +229,7 @@ http://bugs.python.org/issue1222585
_INITPRE = '_OSX_SUPPORT_INITIAL_'
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -553,7 +553,7 @@
+@@ -568,7 +568,7 @@
*\ -s*|s*) quiet="-q";; \
*) quiet="";; \
esac; \
diff --git a/patches/22_all_tests_environment.patch b/patches/22_all_tests_environment.patch
index e32e0dd..3ccb281 100644
--- a/patches/22_all_tests_environment.patch
+++ b/patches/22_all_tests_environment.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue1674555
+https://bugs.python.org/issue1674555
--- Lib/site.py
+++ Lib/site.py
@@ -165,7 +165,7 @@ http://bugs.python.org/issue1674555
os.makedirs(site.USER_SITE)
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -944,7 +944,7 @@
+@@ -959,7 +959,7 @@
######################################################################
TESTOPTS= $(EXTRATESTOPTS)
diff --git a/patches/23_all_h2py_encoding.patch b/patches/23_all_h2py_encoding.patch
index d594f56..8a0fbb4 100644
--- a/patches/23_all_h2py_encoding.patch
+++ b/patches/23_all_h2py_encoding.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue13032
+https://bugs.python.org/issue13032
--- Tools/scripts/h2py.py
+++ Tools/scripts/h2py.py