aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-11-22 15:11:29 +0200
committerAvi Kivity <avi@redhat.com>2009-11-22 15:11:29 +0200
commit0b04e23bfe861522689765229143d9671e2308df (patch)
tree6c270982bd88387870e48e40879d7b0cb978ac32 /Makefile
parentMerge commit '91011d4f3b7c311a42b842f6682ac64a2372d2b7' into upstream-merge (diff)
parentkvm: x86: Refactor use of interrupt_bitmap (diff)
downloadqemu-kvm-0b04e23bfe861522689765229143d9671e2308df.tar.gz
qemu-kvm-0b04e23bfe861522689765229143d9671e2308df.tar.bz2
qemu-kvm-0b04e23bfe861522689765229143d9671e2308df.zip
Merge commit '0e607a80d323ba9f46dee71cd07380c4eb5c2b0a' into upstream-merge
* commit '0e607a80d323ba9f46dee71cd07380c4eb5c2b0a': (22 commits) kvm: x86: Refactor use of interrupt_bitmap kvm: Add arch reset handler Enable migration without shared storage from the monitor Block live migration Expose a mechanism to trace block writes char: rename qemu_chr_reset to qemu_chr_generic_open char: Remove special init_reset handling char: don't limit data sent to backends to 1k per buffer ARM PB-A8 support LAN9118 emulation mips_r4k: fix reset PPC64: map Uni-North AGP bus aka fix Linux boot PPC64: Partial fix to Linux crash: revert to old devfn PCI: make duplicate devfn allocation fatal Do not execute shell scripts directly mips malta: fix indentation target-mips: fix indentation mips-malta: fix reset mips: fix cpu_reset memory leak fix make clean targets ... Carry changes to qemu-kvm-x86.c. Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 93efc9bb2..973f97a97 100644
--- a/Makefile
+++ b/Makefile
@@ -151,6 +151,7 @@ obj-y += qemu-char.o aio.o savevm.o
obj-y += msmouse.o ps2.o
obj-y += qdev.o qdev-properties.o
obj-y += qint.o qstring.o qdict.o qlist.o qemu-config.o
+obj-y += block-migration.o
obj-$(CONFIG_BRLAPI) += baum.o
obj-$(CONFIG_POSIX) += migration-exec.o migration-unix.o migration-fd.o
@@ -250,12 +251,13 @@ clean:
rm -f qemu-img-cmds.h
$(MAKE) -C tests clean
for d in $(ALL_SUBDIRS) libhw32 libhw64 libuser; do \
- $(MAKE) -C $$d $@ || exit 1 ; \
+ if test -d $$d; then $(MAKE) -C $$d $@ || exit 1; fi; \
done
distclean: clean
- rm -f config-host.mak config-host.h* config-host.ld $(DOCS) qemu-options.texi qemu-img-cmds.texi
+ rm -f config-host.mak config-host.h* config-host.ld $(DOCS) qemu-options.texi qemu-img-cmds.texi qemu-monitor.texi
rm -f config-all-devices.mak config-all-devices.h*
+ rm -f roms/seabios/config.mak roms/vgabios/config.mak
rm -f qemu-{doc,tech}.{info,aux,cp,dvi,fn,info,ky,log,pg,toc,tp,vr}
for d in $(TARGET_DIRS) libhw32 libhw64 libuser; do \
rm -rf $$d || exit 1 ; \