aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-12-14 17:14:50 +0200
committerAvi Kivity <avi@redhat.com>2009-12-14 17:14:50 +0200
commitf63802005a1158a604ca2dbef6e7e40a9c96e3bd (patch)
tree4962ef17fc668c70d8b8b8e670fb25bdbf6187c5 /Makefile
parentMerge commit 'b3dfdb5a3bae5fb3170397440dfebd579a3fcb04' into stable-0.12-merge (diff)
parentmonitor: do_info_cpus(): Use QBool (diff)
downloadqemu-kvm-f63802005a1158a604ca2dbef6e7e40a9c96e3bd.tar.gz
qemu-kvm-f63802005a1158a604ca2dbef6e7e40a9c96e3bd.tar.bz2
qemu-kvm-f63802005a1158a604ca2dbef6e7e40a9c96e3bd.zip
Merge commit 'f883e4f7b8f37b53fc54660d20fd36fbe3383f46' into stable-0.12-merge
* commit 'f883e4f7b8f37b53fc54660d20fd36fbe3383f46': (63 commits) monitor: do_info_cpus(): Use QBool monitor: Fix do_info_commands() output monitor: Fix do_info_balloon() output QDict: Introduce qdict_get_qlist() QDict: Introduce qdict_get_qbool() Makefile: move QObject objs to their own entry Introduce qemu-objects.h header file vnc: fix capslock tracking logic. QemuOpts: allow larger option values. scsi: fix drive hotplug. pci: don't hw_error() when no slot is available. pci: don't abort() when trying to hotplug with acpi off. Set default console to virtio on S390x default devices: virtio consoles. add -qmp convinience switch add new -mon switch rework -monitor handling, switch to QemuOpts un-static qemu_chr_parse_compat() default devices: drives default devices: network ... Conflicts: monitor.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 12638f29e..82164a20b 100644
--- a/Makefile
+++ b/Makefile
@@ -94,6 +94,12 @@ ALL_SUBDIRS=$(TARGET_DIRS) $(patsubst %,pc-bios/%, $(ROMS))
recurse-all: $(SUBDIR_RULES) $(ROMSUBDIR_RULES)
#######################################################################
+# QObject
+qobject-obj-y = qint.o qstring.o qdict.o qlist.o qfloat.o qbool.o
+qobject-obj-y += qjson.o json-lexer.o json-streamer.o json-parser.o
+qobject-obj-y += qerror.o
+
+#######################################################################
# block-obj-y is code used by both qemu system emulation and qemu-img
block-obj-y = cutils.o cache-utils.o qemu-malloc.o qemu-option.o module.o
@@ -133,6 +139,7 @@ net-obj-y += $(addprefix net/, $(net-nested-y))
obj-y = $(block-obj-y)
obj-y += $(net-obj-y)
+obj-y += $(qobject-obj-y)
obj-y += readline.o console.o
obj-y += tcg-runtime.o host-utils.o
@@ -165,8 +172,6 @@ obj-y += buffered_file.o migration.o migration-tcp.o qemu-sockets.o
obj-y += qemu-char.o aio.o savevm.o
obj-y += msmouse.o ps2.o
obj-y += qdev.o qdev-properties.o
-obj-y += qint.o qstring.o qdict.o qlist.o qfloat.o qbool.o json-lexer.o
-obj-y += json-streamer.o json-parser.o qjson.o qerror.o
obj-y += qemu-config.o block-migration.o
obj-$(CONFIG_BRLAPI) += baum.o
@@ -254,7 +259,7 @@ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
check-qint: check-qint.o qint.o qemu-malloc.o
check-qstring: check-qstring.o qstring.o qemu-malloc.o
-check-qdict: check-qdict.o qdict.o qint.o qstring.o qemu-malloc.o
+check-qdict: check-qdict.o qdict.o qint.o qstring.o qbool.o qemu-malloc.o qlist.o
check-qlist: check-qlist.o qlist.o qint.o qemu-malloc.o
check-qfloat: check-qfloat.o qfloat.o qemu-malloc.o
check-qjson: check-qjson.o qfloat.o qint.o qdict.o qstring.o qlist.o qbool.o qjson.o json-streamer.o json-lexer.o json-parser.o qemu-malloc.o