diff options
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | Makefile.target | 2 | ||||
-rwxr-xr-x | configure | 5 |
3 files changed, 2 insertions, 7 deletions
@@ -27,8 +27,6 @@ else DOCS= endif -LIBS+=$(CLOCKLIBS) - ifdef CONFIG_SOLARIS LIBS+=-lsocket -lnsl -lresolv endif diff --git a/Makefile.target b/Makefile.target index 47343bb5b..090efb007 100644 --- a/Makefile.target +++ b/Makefile.target @@ -202,8 +202,6 @@ signal.o: CFLAGS += $(HELPER_CFLAGS) ARLIBS=../libqemu_user.a libqemu.a endif #CONFIG_LINUX_USER -LIBS+= $(CLOCKLIBS) - ######################################################### # Darwin user emulator target @@ -1340,9 +1340,9 @@ int main(void) { clockid_t id; return clock_gettime(id, NULL); } EOF if compile_prog "" "" ; then - CLOCKLIBS="" + : elif compile_prog "" "-lrt" ; then - CLOCKLIBS="-lrt" + LIBS="-lrt $LIBS" fi # Determine what linker flags to use to force archive inclusion @@ -1749,7 +1749,6 @@ echo "ARLIBS_BEGIN=$arlibs_begin" >> $config_host_mak echo "ARLIBS_END=$arlibs_end" >> $config_host_mak echo "LIBS=$LIBS" >> $config_host_mak echo "EXESUF=$EXESUF" >> $config_host_mak -echo "CLOCKLIBS=$CLOCKLIBS" >> $config_host_mak echo "/* Automatically generated by configure - do not modify */" > $config_host_h |