summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-10-08 20:32:25 +0200
committerDavid Seifert <soap@gentoo.org>2023-10-08 20:32:25 +0200
commit742f324603932505f02f83dc0d5cf3eef8e2759e (patch)
tree0fe6a02dc5b49faea052144aac7bb2be8eda6530
parentapp-forensics/dfxml: update EAPI 6 -> 8 (diff)
downloadgentoo-742f324603932505f02f83dc0d5cf3eef8e2759e.tar.gz
gentoo-742f324603932505f02f83dc0d5cf3eef8e2759e.tar.bz2
gentoo-742f324603932505f02f83dc0d5cf3eef8e2759e.zip
app-forensics/mac-robber: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/712634 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-forensics/mac-robber/files/mac-robber-1.02-posix.patch19
-rw-r--r--app-forensics/mac-robber/mac-robber-1.02-r1.ebuild (renamed from app-forensics/mac-robber/mac-robber-1.02.ebuild)18
2 files changed, 31 insertions, 6 deletions
diff --git a/app-forensics/mac-robber/files/mac-robber-1.02-posix.patch b/app-forensics/mac-robber/files/mac-robber-1.02-posix.patch
new file mode 100644
index 000000000000..a45d4718e51b
--- /dev/null
+++ b/app-forensics/mac-robber/files/mac-robber-1.02-posix.patch
@@ -0,0 +1,19 @@
+--- a/mac-robber.c
++++ b/mac-robber.c
+@@ -45,6 +45,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -238,7 +239,7 @@
+ /* Make a buffer for the full path
+ * the 2 is for 1 NULL and 1 '/' for recursive directories
+ */
+- path_len = dir_len + MAXNAMLEN + 2;
++ path_len = dir_len + NAME_MAX + 2;
+ if (!(curpath = (char *) malloc(path_len))) {
+ printf("error allocating space for curpath\n");
+ exit(1);
diff --git a/app-forensics/mac-robber/mac-robber-1.02.ebuild b/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild
index b8497f78d985..b5e75816e7ae 100644
--- a/app-forensics/mac-robber/mac-robber-1.02.ebuild
+++ b/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,18 +12,24 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-posix.patch )
src_prepare() {
default
- sed -i -e 's:$(GCC_CFLAGS):\0 $(LDFLAGS):' Makefile || die
+ # just rely on implicit rules
+ rm Makefile || die
+}
+
+src_configure() {
+ tc-export CC
}
src_compile() {
- emake CC="$(tc-getCC)" GCC_OPT="${CFLAGS}"
+ emake mac-robber
}
src_install() {
dobin mac-robber
- dodoc CHANGES README
+ einstalldocs
}