summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-13 03:19:18 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-13 03:27:13 +0100
commit99c0dd546dbb91192a3529d0a03bd94055540bb3 (patch)
treee486fc88841141fd53ea6fc79dab5ed166c9d849
parentdev-lang/dafny: bump to 4.4.0 (diff)
downloadgentoo-99c0dd546dbb91192a3529d0a03bd94055540bb3.tar.gz
gentoo-99c0dd546dbb91192a3529d0a03bd94055540bb3.tar.bz2
gentoo-99c0dd546dbb91192a3529d0a03bd94055540bb3.zip
app-text/pandoc-bin: bump to 3.1.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-text/pandoc-bin/Manifest2
-rw-r--r--app-text/pandoc-bin/pandoc-bin-3.1.10.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-text/pandoc-bin/Manifest b/app-text/pandoc-bin/Manifest
index 0cc6dd247369..848725ad626a 100644
--- a/app-text/pandoc-bin/Manifest
+++ b/app-text/pandoc-bin/Manifest
@@ -1,2 +1,4 @@
+DIST pandoc-3.1.10-linux-amd64.tar.gz 31344010 BLAKE2B 0d7af595800a94002e737eb94b39fc05115a48e5c9c42bf1ad0538f62bf7e188e897cf00a5768502debc49c64e5f100d56110b2bb2a0237f6eca28a71429513c SHA512 f3f434170838f368f6eabc1f7a87e0e2c03dd66d775a271d04ee71ea2049cac0bc207f27e0648994b794380eb0b9bf2dc68ed90159d4cedfa00675191a104def
+DIST pandoc-3.1.10-linux-arm64.tar.gz 34026603 BLAKE2B cd4bdea59495272f273ee4177eb61358af5f068fb8bce104b378de6a61d6f9ea6a579a62409703b62f9d62b705221ad13952a166505387b50740fa4887fd5fd4 SHA512 13121260388ef8fcc45ddd6dca6421a15d2d495cb1bed99095adeaa1f33bc06eb03fc9872be3cf3c198ad588854eb5b07f02bb9b9624b6e053bef23b6152f4ad
DIST pandoc-3.1.9-linux-amd64.tar.gz 31178384 BLAKE2B e9062911de705081d1f8929c8e8d77ab7637351310f9fea8d392561d78943634d8d277b93e91c31d36a5d0b8589d7f989bff0717bda601a0e7e7e2c277b52a63 SHA512 de9b3b496a2816f55dac46c2ff3b5aefc6eced9f73377e4d43783e7d78eaa5893ea0f56c47b5c56e2c8f2561c67024d7f5eaeccb8ab7e87edb7bc8f36312cd36
DIST pandoc-3.1.9-linux-arm64.tar.gz 33852012 BLAKE2B e00997e422057f247385128624d26c9e1134a90147fdaad33fd7586716149ecee6e3f00768eb19fb9898b895d6eabb75924002033dda5958803ec3f3125e40b5 SHA512 406cae4cea2c24bea46bfc479d07094a225208a02bfeefdc1ceaa1f4a7d0c100ab2acb06f2190fe259cadd6cc07efe9b1387044e4e5312ba31025553364c4f3f
diff --git a/app-text/pandoc-bin/pandoc-bin-3.1.10.ebuild b/app-text/pandoc-bin/pandoc-bin-3.1.10.ebuild
new file mode 100644
index 000000000000..b22e74728bcf
--- /dev/null
+++ b/app-text/pandoc-bin/pandoc-bin-3.1.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN//-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Conversion between markup formats (binary package)"
+HOMEPAGE="https://pandoc.org/
+ https://github.com/jgm/pandoc/"
+
+BASE_URI="https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}"
+SRC_URI="
+ amd64? ( ${BASE_URI}-linux-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-linux-arm64.tar.gz )
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+IUSE="+pandoc-symlink"
+
+RDEPEND="
+ pandoc-symlink? (
+ !${CATEGORY}/${MY_PN}
+ !app-text/pandoc-cli
+ !dev-haskell/pandoc
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_unpack() {
+ default
+
+ # Manpages are gzipped.
+ unpack "${S}"/share/man/man1/*.1.gz
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bin/${MY_PN} ${PN}
+ dosym ${PN} /usr/bin/pandoc-lua-bin
+ dosym ${PN} /usr/bin/pandoc-server-bin
+
+ newman "${WORKDIR}"/${MY_PN}-lua.1 pandoc-lua-bin.1
+ newman "${WORKDIR}"/${MY_PN}-server.1 pandoc-server-bin.1
+ newman "${WORKDIR}"/${MY_PN}.1 ${PN}.1
+
+ if use pandoc-symlink ; then
+ dosym ${PN} /usr/bin/${MY_PN}
+ dosym pandoc-lua-bin /usr/bin/${MY_PN}-lua
+ dosym pandoc-server-bin /usr/bin/${MY_PN}-server
+
+ dosym ${PN}.1 /usr/share/man/man1/${MY_PN}.1
+ dosym pandoc-lua-bin.1 /usr/share/man/man1/${MY_PN}-lua.1
+ dosym pandoc-server-bin.1 /usr/share/man/man1/${MY_PN}-server.1
+ fi
+}