summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-07 13:07:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-07 13:17:22 -0600
commitb2561fc1f3f04e8d5f9473034720746e2610e3a3 (patch)
treebe48e5d04085c8c80465894b2681c926446bf10c
parentapp-text/ghostscript-gpl: don't build dynamic modules (10) (diff)
downloadgentoo-b2561fc1f3f04e8d5f9473034720746e2610e3a3.tar.gz
gentoo-b2561fc1f3f04e8d5f9473034720746e2610e3a3.tar.bz2
gentoo-b2561fc1f3f04e8d5f9473034720746e2610e3a3.zip
app-admin/ansible-core: add 2.14.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible-core/Manifest1
-rw-r--r--app-admin/ansible-core/ansible-core-2.14.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/ansible-core/Manifest b/app-admin/ansible-core/Manifest
index 9d8581c01118..ef04f38520cb 100644
--- a/app-admin/ansible-core/Manifest
+++ b/app-admin/ansible-core/Manifest
@@ -4,3 +4,4 @@ DIST ansible-core-2.13.5.tar.gz 13934317 BLAKE2B 27ac2040f3626d645e57fab4df9b1b6
DIST ansible-core-2.13.6.tar.gz 13938462 BLAKE2B bf7bbeb5d5f7e27a2d72a61223559f79971aeb86d91688907c629388cf4c2578c88694f6ca23b22b6f8fe50cdaa909b34c05e9756258a062156a1e5d2bcea3b4 SHA512 2a91916e94bf65f76c450e548c6464660ef0e1a62e17f889785cb94c735c2bf153a2d8eff7a0dac90836a523f5768453bf18c4bdf3cbee0f8916d6cd0b11a902
DIST ansible-core-2.13.7.tar.gz 13940230 BLAKE2B fd3556514f7692b48a66987ff5a084b132217c910ba0b216f2533cd1e542a9b6da6d2aa96e8e32142ab3a6ed7357fc1b68b9827ceaf44b91238bfbcb15b5d026 SHA512 f46d8acb07fa1d397e6e640c52237ed70b575ae0760eeb82b9e41afc6c06d99d341856d6af3452edb82e63a708600c2f348782b8bebc18c0ea9b03a4df80594a
DIST ansible-core-2.14.0.tar.gz 13988948 BLAKE2B 7b68d72c292d8f3e8fb2d0d66fce0eca1de1b74ec1dc3ecaa2c4b37177d693567272260b3e98c9d81f7ff5e5cc4972dfa1f24c9f5e0119bb1da528388081d5fb SHA512 09e5b45608f7e1f341100dd89a6277a71a5ff0a45244cd6862a10d0f35a993c3cf649a5f9936ac726f7e903269f98a975804418516e602b8dd983bfca23c66cb
+DIST ansible-core-2.14.1.tar.gz 14000906 BLAKE2B 86cdf460c3ff6e2877f39f40f9eadc555581045c4a4e1ff301678f9aa7e3116f0bb7084d8841b2bdba50ae119713a226c6353c5e75b9f2a9356073403b04f94a SHA512 d3710aff1dbb04746b663b7c987c3597005dd8633df82f645312e20ddb9c679e7315968c0cf2876ae22ba91d17e4c54ef9cbdb6b825ee1d6f4229e887f8b4571
diff --git a/app-admin/ansible-core/ansible-core-2.14.1.ebuild b/app-admin/ansible-core/ansible-core-2.14.1.ebuild
new file mode 100644
index 000000000000..619c37647ef9
--- /dev/null
+++ b/app-admin/ansible-core/ansible-core-2.14.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.9.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+BDEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}